cancel
Showing results for 
Search instead for 
Did you mean: 

New Workspace: PBI Desktop cannot publish a report sourced from PowerBI dataset

I came around the issue when I created a new type of workspace (the one that doesn't create a corresponding O365 group). I've created a new report by importing data. Then I created a new report that is sourced from that PowerBI dataset located in the workspace and I'm getting Internal Server Error when publishing the report.

 

"An error occured while attempting to publish "Report.pbix": The remote server returned an error: (500) Internal Server Error"

 

 

Status: Accepted
Comments
Visitor

I have the exact same problem with the "new Workspace".  I could upload a report to the workspace and it works fine, but a second upload from PowerBI Desktop fails with the "Internal Error 500".  I can upload to the old (current) workspace that is based on Office Groups.

Visitor

I have the same problem!

Moderator

Hi all, 

 

The same issue has been reported internally: CRI 81344175. Will update here once I get any information. 

 

Best Regards,
Qiuyun Yu 

Moderator
Status changed to: Accepted
 
Visitor

I have the same problem - internal server error 500 when uploading from Desktop to New Workspace. It seems that sometimes data set is uploaded but report is missing (maybe some delay in cloud?). The only possibility is to delete data set and report from Power BI service and upload again. Unfortunatelly, all permissions are gone. 

Please let me know once fixed. Thx Martin

Member

I have this problem with any dataset. Noticing this issue when the app is published. To re-publish from desktop to workspace, I have to unpublish the app and sometimes have to delete the dataset.

Visitor

To: Qiuyun Yu 

 

This is quite annoying basic Publish feature bug. Is there any ETA for fixing?

 

Please let me know as we plan rolling out early next week (September 3rd).

 

Thanks

Martin


JAB Frequent Visitor
Frequent Visitor

I got the same issue. Quite troublesome when you are in the middle of an introduction phase of the service.

Frequent Visitor

I get an error 500 when I want to publish a report to Power BI Service in one of the new workspaces if this report is associated with an APP.

 

If I unpublish the APP, so I'm allowed to overwrite / republish the report.

 

How can I avoid this error.

Occasional Visitor

I get the same error, and like most of the people who've already logged this bug, the timing is terrible as I'm releasing new reports to the whole business with a deadline of 31 August!  Is there an ETA on when this bug will be fixed?