cancel
Showing results for 
Search instead for 
Did you mean: 

New Version of Power BI Desktop breaks existing queries.

After downloading a new version of Power BI Desktop, formualas and queries are throwing Formula Firewall errors and will not process. These were working before.  The failed queries have messages regarding steps in the query that say "xxx references other queries or steps, so it may not directly access a data source.  For example, Formula.Firewall: Query 'AttributeLog' (step 'Extracted Time') references other queries or steps, so it may not directly access a data source. Please rebuild this data combination.

 

These queries all proccessed fine in earlier versions of the Power BI desktop application.  Some of the steps are referring to transformed columns or renamed columns - these should be relatively simple operations.  Why are they throwing errors now?

 

 

Status: Needs Info
Comments
Moderator

Hi @ppfisterer,

 

Would you please share detail steps how create those queries so we can try to test on our side? 

 

Besides, please follow this blog to see if the issue can be solved. 

 

Best Regards,
Qiuyun Yu 

Established Member
Status changed to: Needs Info
 
Frequent Visitor

I solved the issue by setting the Privacy option "Ignore Privacy Levels".

 

In this template, all datasets are comprised of different SQL queries against the same database.

After the initial SQL query, the table with the error is merged with another table that was made from a second SQL query.

 

I don't understand the reason behind firewalling these tables.