cancel
Showing results for 
Search instead for 
Did you mean: 

New Power BI Desktop interface keeps freezing - HELP

Hello, since the new ribbon interface was rolled out, my Power BI Desktop Pro is completely unresponsive and keeps freezing. I cannot minimise, maximise, or move the window at all. The ribbon is completely unresponsive. Occassionally, it will randomly unfreeze, only to re-freeze. This is affecting all my reports. I cannot get any work done. This is an issue with PowerBI and not my system, I have the latest Core i7 with 32Gb of system memory on Windows 10. All my other apps are fine. It was working fine before the new interface was rolled out. Any help would be appreciated, particularly on how I can roll this back to the previous version.

 

Status: New
Comments
Frequent Visitor

@vpatel55 thank you. i've tried this and it still freezes. i can't even move the mouse.

 

New Member

I am running PowerBI desktop on a Mac using Parallels. The screen is frozen from the moment it launches and I can't close it.

Regular Visitor

This issue has been bothering me for the past couple of weeks - running windows 10 64bit. I went into File -> Options -> Data Load and cleared the Data Cache as well as the Q&A Cache. I also went to File -> Options -> Preview Features and disabled the 'Updated Ribbon' feature. It forced me to restart and after the first refresh after restarting, the application crashed. I opened back up and haven't had issues since. I just went through a series of saves and other activity that was locking up my file yesterday and the issue doesn't seem to be recurring... at least for now. Thought I would post here in the event this helps someone else. I do love the new ribbon layout once its working properly 🙂

 

EDIT: I've had the same file open for a few hours, making changes, saving, etc. I've saved around 10-15 times without needing to close down the application and re-open the file. I was lucky if I got 1 or 2 saves in without crashing yesterday.

 

Helper II

This is still happening.  I just loaded the May 2020 update and it immediately went to 100% CPU.  I did the April update and it happened then too.  I've disabled the the new ribbon feature and that didn't help.  

 

FYI, I can still create reports - I use the main report as the source for all the sub-reports.  The subreports are easily accessed and published.  If I have to change a calculation though, or create a column or measure that will be used by all sub-reports, I can't change anything in the main report.