cancel
Showing results for 
Search instead for 
Did you mean: 

Multitenant Database Refresh Problem

Hi,

 

We're having a problem with refreshing database in our raports based on Miltitenant SQL Database.

We have same raports for two companies (they have different, unique login and password for their tenant), and when we refresh the data in PowerBI Desktop everything is OK. When we publish raports to PowerBI Service and we're refreshing the data one raport is OK, but sometimes the secound one have data from the first company! (Due to raport filter there is nothing to see at first, but when we clear filters we can see that this is wrong data). How this is possible? Is there something we can check before? Why PBI Destop works fine, but on Service there is some problem?

 

Best regards

pak

Status: New
Comments
Moderator

Hi @pak

 

Did you connect to on-premises SQL databases or Azure SQL databases? 

In Power BI service, please go to Dataset Settings and specify corresponding credentials for the data source, configure the gateway as well if it's on-premises SQL databases. 

 

Best Regards,
Qiuyun Yu 

pak Regular Visitor
Regular Visitor

It's a Azure SQL database, and we've set the creditians. 
It works ok when we refresh data manualy until we set schedule refresh.

We've set schedule refresh on same time for two reports and after that refresh in one of the raports the data was wrong. All later refreshing (also manual) have still wrong data. We must publish the raport again from PBI Desktop to repair this.

Moderator

Hi @pak

 

I would suggest you create a support ticket to let engineers look into the issue on your side. 

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu