cancel
Showing results for 
Search instead for 
Did you mean: 

Multi Row Card Display Bug With Time Formats

Hi,

 

I believe this to be a bug in Power BI.  Whenever I use a Multi-Row Card, and display a measure formatted with time (or time in a text format), it messes with the display in the card.  Strangely though, when a second Time measure is added, the display seems to return to normal.  I am currently using the Desktop version 2.52.4921.682 64-bit (November 2017).

 

  • The top screenshot shows the card with only numeric data labels, no issue there.
  • The second screenshot shows those same numbers and a measure formatted to time.  For some strange reason, it places the Time data label on the top of the card even though it was placed at the bottom of the Field list, and it's displayed with a larger, bolded format, and without the Category label.
  • The third screenshot has everything from the second screenshot, plus a second time measure, and for some reason, when adding the second time measure, it seems to return the display back to normal.  If I were to remove the second one, it will revert back to the incorrect display again.

 

Power BI - Good Snip - no Time Measures.pngCard with no Time Measures - Looks Good

Power BI - Bad Snip with 1 Time Measure.pngCard with numeric measures and one time measure (in red), incorrectly placed on top, in bold, and with no category label

Power BI - Good Snip - with 2 Time Measures.PNGAdded second Time measure, and all is back to normal again. Note the measure that is squared in yellow is the measure from the last screenshot in red.

Please let me know if there is anything I can do to fix this behavior, or if it is in fact a bug.

Status: Accepted
Comments
Community Support Team

Hi @ScottR-MT,

 

I have reproduced this issue. The good news is no issue in the December version of PBI Desktop that is released in 11 Dec 2017. Please try it out and give some feedback. Thanks in advance.

 

Best Regards,

Dale

Frequent Visitor

Thanks for the reply Dale.  I updated the software and it seems to still have the issue for me.  See the bottom portion of the below screenshot.

 

Power BI - Multi-Row Card in December Update.pngMulti-Row Card still not working properly

Community Support Team

Hi @ScottR-MT,

 

I have submitted the report of this issue to the Product Team: CRI 54330428.

 

Best Regards,

Dale

Established Member
Status changed to: Accepted
 
Community Support Team

Hi @ScottR-MT,

 

I have gotten responses from the Product Team:

 

"By Design, matches Silverlight PowerView layout differences depending on the number and type of fields added to the visual".

 

Best Regards,

Dale

Frequent Visitor

Thanks for the reply, but I'm sure I speak for others when I say that it should offer display settings in regard to this. Why would I want this to function one way when I have only one time measure, and a different way when there are more, without any way to change the behavior?