Showing results for 
Search instead for 
Did you mean: 

Model View Broken in Desktop

Imported three tables from Excel files stored in Sharepoint. When trying to create relationships between the tables in the Model View in Power BI Desktop the tables turn gray, I can no longer move or interact with the tables, or see the relationship lines. The only way to interact with the relationships is using the Manage Relationships button in the ribbon. All three tables have their storage mode set to import, so I should be able to create the data model in the Model View. Please help! I'm using the updated March version of Power BI desktop.

Status: New
Community Support

Hi @alysonsmith


Did the issue happen with all reports or one specific report? 

Did you run the latest Power BI desktop version 2.79.5768.1082 64-bit (March 2020)? 

Please check if your display settings meet requirements listed here


Best Regards,
Qiuyun Yu

Regular Visitor

Hi @alysonsmith , do you solved this issues? I have the same problem. Thanks. 

Regular Visitor

Having the same issue here, to provide more information for the experts - I have loaded the latest version of the Destop (now the April release), and am trying to view the model for a dataset that is built from dataflows.  Please note, I am NOT connecting to a dataset on  (I know I cannot manipulate the model for an imported dataset)


None of the data model connections are visible, but they are still all there, and I can manipulate them using the Manage Connections menu item.

Also, if I roll back to the Feburary release, I can view the connections.


Regular Visitor



I solved this problem by removing the comma characters "," from the table names (especially from these tables that had two commas in their names).


After this, I took control of the tables back into my data model.


Check it out.

Community Support

Hi @Heather_R


Please see my post in this same thread: Please wait for May version Power BI desktop to be released. 


To work around the issue, you can try @martigas's suggestion by removing ; or , from table name. 


Best Regards,
Qiuyun Yu

Regular Visitor

thank you @martigas  & @v-qiuyu-msft  I have made some changes to the table names (and a few column names were also neccessary), that fixed the issue.


In my case, there were no ; or , in either place, but I did have a few : and _ symbols, once both were removed I could see the relationships again.