0 Kudos

Mobile App bookmarks & drill-down not working

Status: New
by CRamirez Regular Visitor on ‎12-03-2018 10:26 AM

I have a report that heavily uses bookmarks as buttons for navigation between tabs/views. On some visuals, I also utilize drill-throughs to other tabs. On the desktop, service, and multiple browsers the bookmarks/drill-throughs work as intended. For some reason though on the mobile app, a few of the bookmarks either do nothing, or I'm sent to the wrong bookmark.

bookmark_menu.png

 

In the screenshot, I have four (4) "buttons" (image uploads) that each have bookmark actions tied to them. I have these buttons in multiple areas of the report, but they all generally have the same function. "Menu", "Sales", and "Rep" all work correctly across the whole report. "Customer" either does not work, or it sends me to the "Sales" bookmark. The "Customer" button works fine on the desktop and service and I never have an issue with it there.

 

 

 

 

 

 

 

As for the drill-through issue, I have two separate tables that I have linked to different drill-through tabs. Both are using the table visual, one is a list of customer numbers, the other a list of all sales reps. The customer number table is linked to a "Customer Profile" tab and the sales rep table is linked to a "Rep Profile" tab. Both work fine on the desktop and service but for some reason they don't work on the mobile app. I click and hold on the specific rep or customer I want, but the only thing that appears is a default tooltip as you can see in the below screenshot.

rep drillthrough.png

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

I have checked and double-checked that these bookmarks and drill-throughs work fine on the desktop and service. I have also removed and republished the report multiple times and neither has worked. All documentation I've found online states that bookmarks and drill-throughs work on the mobile app, but it doesn't seem to be the case? Any information would be appreciated.

Comments
by Moderator v-qiuyu-msft
on ‎12-03-2018 10:55 PM

Hi @CRamirez,

 

Does the issue happen in Power BI mobile app iOS version or Android version? 

 

Please update Power BI mobile app the latest version then test it again. 

 

If it's possible, would you please please share pbix file with us so we can try to test it on our side? You can upload it to your Onedrive and send the share link to me via private message. 

 

Best Regards,
Qiuyun Yu 

by CRamirez Regular Visitor
on ‎12-04-2018 06:23 AM

Hello @v-qiuyu-msft,

 

I'm using the iOS version 17.0 (1.2.181112.113270). I just uninstalled/reinstalled the app and now the bookmarks are working as intended, but the drill-through for my Rep table is still not working. The Customer table seems to be working correctly though. I'm not sure why one would work while the other isnt? I have them set up the same way.

 

I'll see if I can get the pbix file shared with you, I might need to direct you through the report to where I'm having the issue.

 

Thank you,

by Moderator v-qiuyu-msft
on ‎12-06-2018 01:57 AM

Hi @CRamirez,

 

You can upload issued pbix file to your Onedrive and send the share link to me via private message as mentioned previously. 

 

Best Regards,
Qiuyun Yu 

by LuisG2407 Frequent Visitor
on ‎12-21-2018 05:47 AM

Did the drill down option worked at the end? this option has dissapeared on my phone (IOS and Android) 

by Moderator v-qiuyu-msft
on ‎12-24-2018 12:33 AM

Hi @LuisG2407,

 

I'm not able to reproduce the issue on my side with Power BI mobile app iOS 17.1 and android 112378. 

 

Please update your Power BI mobile app to the latest version then test again. If issue still occurs, I would suggest you create a new thread with detail information like how you define the report. 

 

Best Regards,
Qiuyun Yu 

Idea Statuses