cancel
Showing results for 
Search instead for 
Did you mean: 

Missing Report in Workspace

A report has suddenly disappeared for one of our users who has "Member" level access to the workspace. As shown in the screenshot, the report is visible in the sidebar, but not in the main content view. I have confirmed with the user that there are no filters set in his workspace view. The report is also missing from the "Navigation" view when updating the associated app. All other users are able to see the report as expected based on their permissions.

 

I have tried making this user an admin on the workspace, clearing browser cache, switching browsers, and even switching machines, with the same result. So, the issue seems somehow tied to the user account.

 

This is a premium workspace and a Pro licensed user. The dataset for the report resides in a separate workspace.

 

nicg_0-1642434512752.png

 

Status: Investigating

Hi @nicg 

 

Do you mean the only report that the user can’t see is created based on a dataset from another workspace? May I know what kind of role does this user have in the dataset workspace? Or does this user have some permissions like Build permission on that dataset?

 

Best Regards,

Community Support Team _ Caiyun

Comments
v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @nicg 

 

Do you mean the only report that the user can’t see is created based on a dataset from another workspace? May I know what kind of role does this user have in the dataset workspace? Or does this user have some permissions like Build permission on that dataset?

 

Best Regards,

Community Support Team _ Caiyun

nicg
Advocate II

Not exactly. The missing report is tied to a dataset in another workspace, but several others are tied to the same dataset and the user can see those just fine. For instance, in the original screenshot, the "FEBI 2 Dist dash" report is tied to this same external dataset, but the user has no trouble viewing it in the workspace. But "FEBI 2.0 Distribution Dashboard" only shows up in his sidebar.

 

User is part of an AD group that has permissions on the dataset through a published app. The app has Build and Reshare settings enabled. The AD group appears to be listed correctly on the dataset > Manage Permissions page with the appropriate settings, "App (Reshare, Build)", and no one else in that AD group is having issues.

v-cazheng-msft
Community Support

Hi @nicg 

 

Thanks for your reply! Could you please make these attempts?

  • Please check the manage permissions page of the report to see whether this user or its group listed there?
  • If you copy the link of this report from your browser and let the user who havs view issue to access it, will this user view it successfully?
  • If you directly give permission of the report to this user, will this user view it successfully?

 

Best Regards,

Community Support Team _ Caiyun

nicg
Advocate II
  • He is listed on the report "Manage Permissions" page as "Member (Owner)".
  • Yes, he can view it from the link, as well as through the app.
  • Can you clarify? I'm not sure what is meant by "directly give permission".

Thanks

snunn
New Member

I am having the same problem with two different reports located in two different workspaces.  I have admin permissions and was the report author.