cancel
Showing results for 
Search instead for 
Did you mean: 

May 15 2017 Release (2.46.4732.721) Failure to Refresh

This has been an issue since the Original April Release.  I continue to revert to the March 10th release as it is the last release that allows me to refresh my data.

 

I just tried the latest May release and the issue persists...

 

I have received two similar error messages between my two data models:

 

First: "DataFormat.Error: You attempted to open a database that is already opened by user 'Admin' on machine 'xxxxxxx'.  Try again when the database is available."

 

Second: "DataFormat.Error:  The database has been placed in a state by user 'Admin' on machine 'xxxxxxx' that prevents it from being opened or locked."

 

I have found that the error only occurs when refreshing from a database that sits on our network drive - I am using an Access Database as the datasource and if I copy the database to my local machine and redirect the datasource in Power BI Desktop, then the model refreshes without issue.

 

Please fix this issue - having to copy the database locally on my machine in order to refresh is not a viable work around.  I continue to run the March 10th release until this is fixed, wishing that I could access some of the new features that were introduced in April and May...

Status: Accepted
Comments
Microsoft

@nbailey

 

I can repro the same issue as you with a .accdb file which is about 300 MB. But I can also repro it with Mar 2017 version of Power BI Desktop.

I’ve reported it internally to Power BI Team: CRI 37729276
I’ll post here once I get any update about it.

 

Best Regards,
Herbert

Impactful Individual
Status changed to: Accepted
 
Advocate I

Thanks Herbert! 

 

As indicated, I have continued to revert back to the March release as this is the last release that works for me.  I am running the 64 bit version which I failed to mention in my first post.  Below is the full version information that I am running successfully:

 

Version: 2.44.4675.521 64-bit (March, 2017)

 

I look forward to this issue being resolved so that I can take advantage of the recent new features!

Microsoft

@nbailey

 

Is it possible there's an old *.laccdb file on the network drive that's blocking access? Is the file likely in use by others when you try to read it? If so, what happens if you first make sure everyone exits Access and then delete any outstanding *.laccdb file and then try to connect -- do you still get the same error?

 

Additional feedback from the Access team:

The first message is given when another user has the database file opened exclusively, preventing any other user from opening it.
The second message is given when another user has the database open (not exclusively), but the current user is trying to get an exclusive lock.
Are multiple users opening the database?  It is on a fileshare, so this seems plausible.
In general, multiple users cannot use a database if design changes are being made (modifying the design of forms, queries, etc., which is what requires an exclusive file lock), although it should be allowed if no design operations are occurring.
 
Best Regards,
Herbert
Advocate I

Hello,

 

The Access DB is on a network share, however access is very contained with just 3 other users having access to where the DB is stored.  When I began having the issues, I verified that the DB was not locked and that there was no one else in it.  For extra certainty (other than confirming the other 3 users didn't have it open), I copied the DB and repointed the source to the copied DB with no luck.  However, as stated previously, if I take the DB off the network, the model updates without issue.  Both errors occasionally list the user and machine as null ('').  When the user and machine are indicated, the user is always 'Admin' and the machine is always my own.  If I continue to attempt to refresh, sometimes other errors pop up, like "Expression.Error: The key didn't match any rows in the table." or "DataFormat.Error: Could not use '(database name)'; file already in use."

 

I have two separate data models which produce the same error sets.  As soon as I reinstall the March release, both update without any errors.

 

Advocate I

I just performed some additional testing on the most recent May Release after finding that I could refresh a 3rd, very simplistic model that I created recently which sources one table from Access and one table from Excel.  Below are the tests I tried and the results:

 

On my most complex data model, I successfully added a new table, sourced from Excel.  Once this source was introduced, I was able to intermittently refresh the entire model, including all of the original tables from the Access Database.  However, occassionally I would still get the same error messages previously reported.  Again - most complex model I have which wouldn't refresh at all no matter how many times I tried, but as soon as I introduced the Excel source, I was able to successfully refresh the entire model intermittently.

 

I also created a new PowerBI Desktop file and started loading tables from my Access DB, refreshing the entire model after each table load.  All I did was load tables - I didn't configure or transform anything.

 

Test 1:  I loaded 9 tables, one at a time and I was able to successfully refresh the entire model after each table load.  Then I loaded 2 tables simultaneously which successfully loaded into the model.  However, at this point I started getting the same load errors as previously detailed when trying to refresh the entire model.

 

Test 2:  I loaded 9 tables simultaneously and refreshed the entire model afterwards with no issue.  Then I loaded 2 more tables, one at a time.  The entire model continued to refresh without issue.  Upon loading 1 more table (bringing total to 12), attempts to refresh the entire model then produced the errors.

 

The first 11 tables in each test were the same and varied from very small tables, to a table with 100k+ rows of data.  The last tables loaded in each test (10th, 11th - and 12th in test 2) were all very small tables with just a few rows and a few columns.

 

Note:  All sources used were in the same network location.

Microsoft

@nbailey

 

Thanks for the detailed information. The team has filled a bug for it and will triage appropriately.

 

Best Regards,
Herbert

Advocate I

Hi @v-haibl-msft,

 

I see a new version was posted on 6/10 (version 2.47.4766.542) - do you know if this bug was addressed in this release?

 

Thanks,

Nate

Regular Visitor

Nate - I am having the same issue, and was just searching to see if this issue was being worked on.

Noticed in the last two versions, and still an issue in Version: 2.48.4792.721 32-bit (July, 2017)

 

Looking forward to a solution. I can play a game of refreshing the linked data tables one at a time while watching for the lock to come on, and go off in windows explorer. If the lock does not go away, I can save the PowerBI book, close PBI, and the locks will drop. This has been how I am getting by.

 

I also note that just opening a PowerBI file will send odd flutters of locks through the linked databases without a request for refresh being done.

 

Looking forward to a fix.

Geoffrey

 

Advocate I

Don't hold your breath - they went silent on me since that May 24th post.  It apparently isn't affecting many users, otherwise it'd be addressed by now.  I've simply been trying every release that comes out and then reverting back to the March 10th release, which is the last release that allows me to refresh the model properly.  Quite annoying.