cancel
Showing results for 
Search instead for 
Did you mean: 

Matrix Non-Stepped Layout Removes Overflow Grand Total Row

Normal behavior for a stepped matrix with more rows than currently displayed is to show the grand total as a floating row at the bottom. However, when stepped layout is turned off, so is this grand total, regardless of subtotal and per row subtotal settings. Here are screenshots showing the current behaviour (pardon the heavy redaction). The ideal behaviour would be to continue showing the grand total even in non-stepped layout. All row subtotals are enabled in both screenshots. Using version 2.60.5169.4101.

Matrix Stepped.pngMatrix UnStepped.png

 

 

Status: Needs Info
Comments
v-qiuyu-msft
Community Support

Hi @LukeWalker,

 

I'm not able to reproduce the issue in Power BI desktop version 2.60.5169.4101 64-bit (July 2018). Please download the report and test on your side to see if it works. 

 

q6.PNGq5.PNG

 

Best Regards,
Qiuyun Yu 

v-qiuyu-msft
Community Support
Status changed to: Needs Info
 
LukeWalker
Advocate IV

Hi @v-qiuyu-msft,

 

This behavior occurs when the matrix overflows the visual bounds and a scroll bar appears. If you set the visual height to 360 px, notice the row grand total dissappears in non-stepped mode. When stepped mode is re-enabled, the grand total reappears. 

 

Regards,

 

Luke

v-qiuyu-msft
Community Support

Hi @LukeWalker,

 

After change the visual height in my sample report to 360, turn off the stepped layout for row headers, when we scroll down to the bottom of the matrix visual, the grand total row is still here. Please update your Power BI desktop to August version 2.61.5192.541 then test again. 

 

q1.PNG

 

Best Regards,
Qiuyun Yu 

LukeWalker
Advocate IV

Hi @v-qiuyu-msft,

 

I do see the grand total when I scroll down to the bottom currently. However the difference is that in stepped view, the total is floating (i.e., it displays even when I'm not scrolled to the bottom). In non-stepped view, as you pointed out, you need to scroll to the bottom to display the total. I'd think this behaviour should be consistent across matrix layouts.

 

Regards,

Luke

emarc1
Helper II

I agree with LukeWalker here. Only being able to see the grand totals at the bottom of a whole data set isn't helpful. If there are thousands of lines, it can take a long time to scroll all the way down... Being able to see the grand total, fixed to the bottom of the frame, like with the way it works with stepped rows, is much more helpful.

VV24
Helper II

Totally agree, this does not work when you have more lines than the page size. Might be nice to have an option to toggle on or off the ability to have a overflow grand total.

vickyd
Helper V

Agree. This needs to be an option or default behaviour. This is one of those little annoyances/limitations with the matrix view that would significantly improve usability if addressed. 

wancchan4
Frequent Visitor

Agree, I need to scroll down to the bottom of report to see the grand total.

It is not ideal if I get a very long report

valdano34
Frequent Visitor

Needed here as well!

 

The only available workaround is to display the row total on Top, which is OK-ish but is it such a big deal to make floating on the bottom ? 

 

valdano34_1-1601061462723.png

 

valdano34_2-1601061545106.png