cancel
Showing results for 
Search instead for 
Did you mean: 

Map (Bing) showing an offset location to actual co-ordinates

This isn't an instance of the incorrect City being shown in another country, this is an issue where the Map (Bing) shows location dots on the map perfectly fine in PowerBI Desktop but as soon as you upload it to PowerBI Online, it shows an area SE by a large distance to the Lat Long location. It does this where it's zoomed out to occupy a cluster of location dots and even when you click on a specific site in a table, the map zooms to a SE area.

It's important to note that the location dots are showing in the correct locations on the map, just the auto zoom to showing an area to the SE of the correct locations.

This has been tested where the source data is from a DW and Excel spreadsheet.

It worked fine until this morning.

Status: New
Comments
New Member

We are getting the exact same issue, same timing. Map extents zoom to a location ~ 50kms to the south east of the true location, but the points are in the correct location (found by manually zooming).

New Member

Same problem here, auto zoom on map does not work properly in the online version. Desktop version works fine. 

 

Frequent Visitor

Same issue here, ever since the map update to show an oversized 'Terms' hyperlink in the middle of it, a couple of days ago. Just in the service though, Desktop is fine.

Regular Visitor

Same issue here, bing maps is showing the wrong location using lat long on service (premium node), someone tripped on a wire at Microsoft! Desktop has no issues.

New Member

I have the same issue, will you have any idea?

New Member

Same issue. Very frustrating. Have had to disable auto zoom and reformat report as a temporary workaround

Moderator

Hi all, 

 

It's a known issue. You can see details below: 

 

Impact:
Users of the Bing Map visual may notice the auto-center feature is not locating the center correctly when all the data points are within a very small region (e.g. same city), or if they only have one data points. Each time they filter or cross-highlight, the autocenter may move to an incorrect location.

 

Workaround:
None – users will have to manually zoom out or pan the data points into focus each time they filter or crosshighlight.

 

Fix Status:
ETA 10/4.

 

Best Regards,
Qiuyun Yu 

Regular Visitor

Also having same problem in service - bubbles not appearing, and location off by about 20 miles or so. When downloaded, it again works fine in desktop.

New Member

We are experiencing the same issue. I do remember seeing an error message, zoom = null after deploying to service but refreshed in desktop and it was fine. The issue only exists in service, but desktop works fine.

Regular Visitor

Hi All,

   Getting the same issue here...Started to happen on Wednesday (NZT). Below is an example... The maps both show the location of gambling venues in Auckland. In both cases the position of the locations on the map is correct, but the map is not centering on the locations properly.  As stated by others this only happens on the web service and not in Power Bi Desktop.Power BI Prob.jpg