cancel
Showing results for 
Search instead for 
Did you mean: 

Maintain Layer Order not working in PBI Service

See here: https://community.powerbi.com/t5/Desktop/Maintain-layer-order-does-not-work-when-published-to-servic...

 

In neither reports with previously working 'maintain layer order' or new reports this feature seems to be working as expected. I can confirm this was working a week ago, but no longer does.

 

Can be reproduced by the following steps:

1. Create a new .pbix file

2. Create a rectangle in one color (blue)

3. Create a second object (can be anything - slicer, button, shape all tested) in a different color (red)

4. Send the first rectangle to back in case it isn't already (it should already be in back)

5. Select blue rectangle, tick 'Maintain Layer Order'

6. Upload to service

7. Click blue rectangle

 

Observed results: Blue rectangle covers up the red rectangle and layer order is not maintained

Expected results: When clicking the blue rectangle, layer order should be maintained and it should not cover up the red rectangle.

Status: Delivered
Comments
Nexter
Advocate II

@andrewbrick I did not have to republish my reports, the fix just automatically kicked in for all of my reports this morning.  You should definitely follow up with MSFT.  

rhernke
Advocate I

@v-chuncz-msft 

 

Looks good on our end, reports have the expected behavior without republishing. Thanks for following up!

jrichardhs1218
Regular Visitor

@andrewbrick 

I am also still experiencing this issue in the Government Cloud. Hopefully the fix will be rolled out for us soon!

v-chuncz-msft
Community Support
Status changed to: Delivered
 
Yasir90
New Member

My data has not refreshed i am trying and getting error

Error -Details

Cluster URI: WABI-WEST-EUROPE-E-PRIMARY-redirect.analysis.windows.net Activity ID: 4b47d5b6-3160-4a1f-9fb7-e0820a118654 Request ID: 07ce5147-818e-4e6b-fb60-3afafc141cfb Time: 2021-08-06 20:39:39Z

 

Something went wrong

It looks like scheduled refresh failed because the on-premises gateway restarted while refresh was happening. Double-check that the data gateway is continuously running for the next scheduled refresh.

Aforementioned error while refreshing and couldnt complete refresh , i tried to upgrade gateway and unisntall and install again still facing since yesterday. Please help....... :   if solution kindly email  at y.mobin@naqel.com.sa  or  ammar.yasir.amin@gmail.com

Yasir90
New Member

Cluster URI: WABI-WEST-EUROPE-E-PRIMARY-redirect.analysis.windows.net
Activity ID: 4b47d5b6-3160-4a1f-9fb7-e0820a118654
Request ID: 7ee2e331-b581-718f-0c34-95f2ab46fc0c
Time: 2021-08-06 20:21:35Z

 

Please help in Saudi arabia region is there any problem gateway refresh from Microsoft.

Something went wrong

It looks like scheduled refresh failed because the on-premises gateway restarted while refresh was happening. Double-check that the data gateway is continuously running for the next scheduled refresh.