cancel
Showing results for 
Search instead for 
Did you mean: 

Loading a remote parquet file causes an error

Even though the native Parquet connector is scheduled to be available on Mar 2021, I already have it showing up in my PowerBI Desktop. I have a small parquet file hosted on a webserver and when I download this file and open it using this new Parquet connector, it works fine.

 

But when I try to load this from my webserver via http or https, I get the following error in PowerBI:

streamed-binary-values-error.PNG

Does anyone know how I would be able to solve this issue?

 

PS: I have tried the commercial CData Parquet connector and that worked fine, but I rather would like to use the native Parquet connector in PowerBI.

Status: New
Comments
v-chuncz-msft
Community Support

@Maurice_S 

 

The latest version (2.88.1144.0) works fine for me. You may check if the URL is correct.

Maurice_S
Regular Visitor

Hi @v-chuncz-msft 

 

Thanks for your reply. I am using the same version, Version: 2.88.1144.0 64-bit (desember 2020). The URL is correct, I enter the same URL to download it to local and I see also the preview.

 

It seems that it depends on the size, or a particular value that is being imported. When I have a parquet file with 10000 rows/148 KB, 50000 rows/648 KB, 100000 rows/1.3MB, it works fine, but 500000 rows/6.2MB fails when using a direct link. I get to see the truncated preview, but when loading it gives the error message: "Parquet.Document cannot be used with streamed binary values."

 

However, when I download the same file loading works fine.

 

As an additional test, I have concatenated 5 times the 100000 same rows that worked fine, and this gives the same error, ruling out that it is a particular value in the parquet file that produces this error.

 

I suspected it had something to do with the SNAPPY compression because it is not splittable, but the same parquet file using no compression causes the same issue.

 

To reproduce, I have a file hosted at http://www.datec.no/dev/public.parquet that is based on the public available data.gov dataset (Allegheny County Property Sale Transactions).