cancel
Showing results for 
Search instead for 
Did you mean: 

Lag, slow load, just spinning

I see previous reports on this issue.  It wasn't affecting me until the last few days.  Now many of my visuals in PBI Service just won't load.  Spinning all the time.  It was working fine and now it is not.  It is a PBIX file published from desktop to PBI Service.  I tried updating PBI Desktop to the latest release, and republishing, also tried saving PBI Desktop as a new file and publishing a new report and data set to the PBI Service.  Same issue.  

 

It is not usable at all at the moment Smiley Sad

Status: New
Comments
Frequent Visitor

I am having the same issues today in Power BI service. Several of our users are reporting lags and spinning reports that won't load. We are in the central region and are using the data gateway with SSAS tabular. This is really starting to slow down our adoption of Power BI. I can see (in SQL Profiler) all our users signing out of Power BI and going back to our SharePoint/SSAS Tabular deployment on a regular basis. 

Moderator

@cproloff@HughJohnson Please check if the visual in Power BI service meet the same scenario mentioned in this site: https://powerbi.microsoft.com/en-us/support/.

 

q3.PNG

 

Best Regards,
Qiuyun Yu

 

 

 

 

Frequent Visitor

 @v-qiuyu-msft Thank you.  I am not using Direct Query though.  The data source is an OData feed that at the moment I refresh manually when I need.  Refresh seems to work fine, taking just over a minute.  Last week all the report pages loaded ok.  Since about Friday only some of them do.  It seems in particular that Slicers are struggling to load, but also many table visualisations.  It is not a case of wiaitng and eventually they load.  Even if I leave it running overnight they don't load.

 

Any ideas? Should I wait for it to be fixed, or is there something I should do to restructure my report pages?

Frequent Visitor

@v-qiuyu-msft I would add though that although I am not using Direct Query, I do have many calculated columns and measures that use those columns.

Frequent Visitor

@v-qiuyu-MSFT Thank you for the reply. The reports that I am using do not rely directly on calculated columns. I am also not getting any error messages. The visuals just simply won't load and you get the spinning wheel. When this occurs, it typically freezes up other areas in Power BI as well, including the settings and other screens. I have also experienced filters that spin and won't load. This issue has been intermittent for the past couple of weeks, but has gotten really bad this week. 

Moderator

@HughJohnson@cproloff I would suggest you create a Power BI support ticket by click the Create support ticket button at the end of this site to get dedicated support.

 

Best Regards,
Qiuyun Yu

Frequent Visitor

@v-qiuyu-msft thanks, I have just done that

Frequent Visitor

Thanks for the warning regarding the fix. I am experiencing most of the problems with the narratives visual.

Frequent Visitor

@v-qiuyu-msft I have just found a workaround that soles the problem Smiley Happy Use IE instead of Chrome.  That has solved the problem for me.  I should have thought to try that before, though it was working on Crome last week.

Idea Statuses