cancel
Showing results for 
Search instead for 
Did you mean: 

KPI Visual not auto displaying the units correctly

Hi,

 

When you choose the auto on the display units in the indicator for the KPI visual, you it doesn't do anything to the indicator. You would have to choose thousands/millions manually which ruins the report, since the users are able to see data for days, months, years and so on.

 

With AutoWith AutoWith MillionsWith Millions

 

Is there a solution or is it a bug?

I found a similar post with the same issue:
https://community.powerbi.com/t5/Issues/KPI-Visual-Indicator-Display-Units-Auto-not-working/idi-p/63...

It is marked as solved which I don't think it is.

Status: Accepted
Comments
v-yulgu-msft
Microsoft

Hi @copykai ,

 

I have reported this problem internally, CRI: 115940680. Would update here once I get any response.

 

Best regards,

Yuliana Gu

v-yulgu-msft
Microsoft
Status changed to: Accepted
 
copykai
Resolver I

Hi,
I discovered that this only occurs when the data type is Whole Number.
If Decimal is chosen then it will display the units correctly.

MaKH
Regular Visitor

Hi, if decimal is chosen with 2 decimals (or more) and thousand-separator, it is shown correctly, but if you decrease to 1 or 0 decimals it is not working (from my experience). 

Anonymous
Not applicable

@MaKHThis fixed the issue for me as well. Thanks!

jochenj
Advocate II

run into the issue with latest December 2019 release , this is still an issue 😞

DisplayUnits="Auto" does only work if measure is formated with 2digit decimal places, all other combinations (Measure Datatype/format "Whole number" or "deciimal" with other then 2digits) kill the automatic scaling, this is really a showstopper for usage

devikamanian
Frequent Visitor

Is this issue resolved? I still see "Auto" option is not working in KPI visual. It shows the same value as "None". 

sfog
Advocate I

This seems to be partially solved. If you add a currency ($ for instance) both the Indicator and Goal will automatically format the number to M/K etc. However, if you do not have a currency assigned in Column Tools >> 'Display the values in this column as currency' - then the Auto setting does not work. 

 

If you do notwant to use a currency indicator, you can sovle this manually by creating a Dax measure and manually formatting it as #,##0M if the value is greter than 1,000,000.