cancel
Showing results for 
Search instead for 
Did you mean: 
0

KPI Visual - Indicator Display Units - Auto not working

Hi,

 

On the KPI visual, in the settings of the Indicator you can choose to have Display Units set to Auto.  This is what we want to do but they are not changing to be abbreviated (e.g. 619461 is showing instead of 619K).  If I put the same value on a regular Card then the Auto functionality works correctly.   

 

image.png

 

Regards, David

Status: Delivered
Comments
v-qiuyu-msft
Community Support

Hi @Anonymous ,

 

This is dues to the different definition of the "Auto" unit for visuals. If you try to use the clustered column chart to display the value, it will use "M" unit though unit settings is "auto". 

 

w5.PNG

 

The issue is more likely a feature request. You can submit your idea here: https://ideas.powerbi.com/forums/265200-power-bi-ideas

 

 

Best Regards,
Qiuyun Yu 

v-qiuyu-msft
Community Support
Status changed to: Delivered
 
Anonymous
Not applicable

Hi @v-qiuyu-msft  - thanks but I'm a little confused.  How can we get the KPI card to show ANY abbreviation?  The issue is that it doesn't show any at all. It's not a case of K vs M.  THanks

v-qiuyu-msft
Community Support

Hi @Anonymous, 

 

You can set different abbreviations by choosing desired unit. 

 

q1.PNG

 

Best Regards,
Qiuyun Yu 

alfa
New Member

Hi @v-qiuyu-msft,

I have the same issue. The "auto" option does the same as the "none" option i.e. nothing.

 

The card needs to dynamically be able to choose the approriate abbreviation for our use case, as different users will see very different values when they view the report.

 

I assume, as with all other visuals, that this is the intended use of the "auto" option?

sam_deason
Helper I

We just ran into this issue as well. I'm not sure how you delivered on this as it really does seem like a bug. 

 

I think we need more explanation to why Cards and KPI would behave differently. 

jochenj
Advocate II

run into the issue with latest December 2019 release , this is still an issue 😞

DisplayUnits="Auto" does only work if measure is formated with 2digit decimal places, all other combinations (Measure Datatype/format "Whole number" or "deciimal" with other then 2digits) kill the automatic scaling, this is really a showstopper for usage