cancel
Showing results for 
Search instead for 
Did you mean: 

June 2020: "Pending Changes in Your Queries That Haven't Been Applied" won't go away

Version 2.825858.641 x64 (June 2020)

"Store datasets using enhanced metadata format" IS enabled in Preview Features.

 

I have been running into issues when I attempt to use parameters in an M-query to retrieve and transform data from a Sharepoint site in custom M queries created from the "New Source" -> "Blank Query" function in the Query Editor's UI.

 

A collection of queries currently uses two different parameters, one for the URL to the Sharepoint Workspace and one for the URL to the desired file's directory on the SP site:

Source = SharePoint.Files(PBISharepointBudgetWorkspaceURL),

#"fp_SharepointArtifact" = Source{[Folder Path=PBISharepointBudgetWorkspaceDimensions, Name="ExpenseActuals.xlsx"]}[Content]

 

Despite the query editor successfully being able to ETL the desired files, upon selecting "Close and Apply", the changes appear to go into effect, but then the warning notification "There are pending changes in your queries that haven't been applied" appears at the top of the report canvas pane with the options to "Apply changes" or Discard changes":

 

Pending Changes NotificationPending Changes Notification

 

Selecting "Apply changes" appears to apply a transformation to "Queries Metadata":

Apply changes Query Metadata exampleApply changes Query Metadata example

 

but as soon as its loaded the warning notifcation to apply or discard immediately appears again.

 

Selecting "Discard changes" indicates that I've changed something about the parameter:

Apply changes Queries Metadata exampleApply changes Queries Metadata example

Clicking "Discard" appears to have no effect whatsoever and the warning notification persists at the top of the report canvas pane.

If I retroactively hardcode one of the parameters, replacing its occurrence in all instances but keeping the other parameter in each query where it's used as an argument, then the "Discard Changes" dialogue tells me that the change is then occurring with the other parameter.

 

I don't know if this is a function of the new enhanced metadata format or not. My theory is it has to do with the new data format and/or the latest version of PBI Desktop. Seems like other folks have had the same issue in the past under different versions of the desktop application and the only workaround was rolling back to a prior version. 

 

Has anyone found a better way to resolve this issue?

 

Status: New
Comments
Sussibar
Advocate I

UPDATE: I am theorizing that the issue potentially might stem from a number of different things.

 

I originally had each of the parameters' "Enable Load" property in the context menu disabled; when I enabled that property, making the parameter tables visible in the model, the issue seemed to go away. But I have plenty of models where parameters aren't enabled and they work just fine, so I'm a little confused there. I'm somewhere between believing it might have to do with how it was created (using "Blank Query" instead of "Manage Parameters") and it might have to do with load options, using the new metadata format, or a combination of some or all the above. Perhaps I am naively assuming the two UI buttons, "Blank Query" and "Manage Parameters", are just two different methods whose end result is a query, and perhaps internal implementation has different side effects. And it's completely possible my hypotheses are invalid and it's a completely separate issue.

 

WORKAROUND: 

In any case, I ended up first removing the offending parameters' queries entirely (I had to temporariliy hardcode all the instances where they were called in other queries) and re-entering them through the "Manage Parameters" function. All also have the "Enable Load" property disabled, and so far I haven't had any more issues. But as I previously said, I'm not 100% certain why my issue was occurring in the first place.

v-chuncz-msft
Community Support

@Sussibar 

 

You may check Considerations and limitations and create a support ticket for assistance if necessary.

edhans
Super User

I had this problem back in May and the solution was, disable the enhanced metadata preview feature. It is DEFINITELY not ready for prime time. It was giving me similar errors with Apply All not going away, and it even lost much of my Power Query M code, because the new format stores the code in a different place.

 

I'd definitely disable. Report the bug, but don't use it yet. Sorry to see it isn't any better in June than it was in May and April.

rpiboy1
Helper V

I'm having the same issue where the Apply Changes banner will not go away, there are no visible errors. I do not have any parameters in my model. I do have a bunch of tables that are set to not load as I'm using those tables to build my actual data model. I've tried everything suggested to date with no success.

 

Frustrated...

edhans
Super User

@rpiboy1 do you now or have you ever with that file had the Enhanced Dataset preview feature enabled?

rpiboy1
Helper V

yes, I previously had that feature turned on to take advantage of improvements with Tabular Editor that the enhanced Meta data features provided.

edhans
Super User

@rpiboy1 That is the issue. I don't know how to fix it. I ran across this issue when I enabled the feature. The solution I went with was brutal.

  1. Copy all M code from old report to new report where that ehanced metadata feature is disabled.
  2. Load all applicable data.
  3. Copy the DAX measures one at a time to the new report.
  4. Create new report pages with the same names.
  5. In the old model, press CTRL-A, CTRL-C on every page, then CTRL-V in the corresponding page of the new report.
  6. Fix any other issues, like bookmarks, filters, etc. that cannot be copied.

That enhanced data feature has really messed me up on 3 different reports, and 1 of them I've totally rebuilt. The other 2 are on my list.

MS has a long LONG way to go to make that feature ready for prime time, and you should be very very careful of using it on production reports.

PBIDAX
Frequent Visitor

@edhans has this been reported to MS (support ticket etc.)? I'm having the same issue but I'm able to resolve simply by hitting apply changes every time I open the PBIX file. I think it started when installed the External Tools tab (Tabular Editor) but can't be sure. 

 

I've added my vote to @Sussibar issue above for whatever that's worth.

 

Hope someone from MS can add some light here? (other than just pointing us to another location)

edhans
Super User

@PBIDAX Not from me. I reported an issue that they have supposedly fixed back in May, but I have not used this enhanced dataset feature since then so I haven't tested the fix or subsequent months of builds with that feature.