cancel
Showing results for 
Search instead for 
Did you mean: 
0

Issues with PowerBI desktop versions: 2.111.590.0 64-bit (November) and October, reports do not open

Reports having composite model do not open with PowerBI Desktop October and November (2.111.590.0 64-bit) releases. Same reports open with earlier versions (e.g. September).

Symptoms: Opening report just hangs presenting the startup screen. No error messages. Currently experimenting with November release and opening has been continuing for about 1 hour now. Windows task manager shows 0% CPU (for PowerBI) and 12-13% for Microsoft Analysis Services.


The same reports work still in PowerBI Pro and Premium capacity (as an app) - and with September version of Desktop.

 

Reports having this issue are using composite model (storage mode: Mixed): 

1. direct connection to SQL Server Analysis Services database (PowerBI datamodel)

2.  import of local files

3. import using DAX query from the same SQL Server Analysis Services database having the direct connection (to create couple of needed code tables). 

4. added local columns on a table using direct connection

5. measures both in corporate model and local model

Note: depending on the report it may use 1&2&5 or 1&4&5 or 1&2&3&5.

 

Creating a new report from scratch using composite model works and so do old reports using either import or live connection to the same SQL Server Analysis Services database described above.

 

What I have done to solve the problem:
1. Removed and reinstalled different versions of PowerBI desktop
2. Tested with and without Webview2 (with October PowerBI desktop)
3. Tested by waiting long time (hour?) for a report to open.
4. Downloaded PowerBI desktop report file from Premium (guessing that file might be "rebuild" during the process)
5. Only solution is to uninstall new PowerBI desktop version (October or November) and install old version (September). Based on this problem is not on my environment but on PowerBI desktop version.

Similar issue has been reported 6.11.2022 (11/6/2022) by @ANTOS  post Issues with latest release of Power BI (October 2022 Update (2.110. 341.0))  

Status: Delivered

Hi @AJH 

I am so glad to hear that your issue has been fixed . Thanks for your reply .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
ANTOS
Advocate I

@AJH 

thanks for your input on this topic and i can confirm that i have the same problem with the latest version 2.111.590.0 64-bit... so i am still using the one from September.

 

i haven't tried to rebuild my reports because they are close to 100pages and it is not possible to recreate them within a reasonable time frame... 

Ailsa-msft
Community Support
Status changed to: Investigating

Hi @AJH 

If you download the pbix file from Service and open it in Desktop , can you open it ? No errors at all in your opening process? 

If this is the case above, you can create a support ticket for free and a dedicated Microsoft engineer will come to solve the problem for you.

The link of Power BI Support: https://powerbi.microsoft.com/en-us/support/

For how to create a support ticket, please refer to https://community.powerbi.com/t5/Community-Blog/How-to-create-a-support-ticket-in-Power-BI/ba-p/6830...

 

Best Regards,
Community Support Team _ Ailsa Tao

AJH
Regular Visitor

Thank you Ailsa! I will make a ticket. As described in this post: If I download the pbix file (having composite model created on September version or before) from Service and open it in Power BI Desktop (October, November), I cannot open it. There are no error messages in my opening processes, PowerBI desktop just hangs until I kill the process in the Task Manager. Same file opens with not issues when I use Power BI Desktop September version.
Br Ari

AJH
Regular Visitor

@ANTOS FYI: Microsoft is investigating this issue. I will inform after issue has been solved. Br Ari

ANTOS
Advocate I

@AJH i just tried the December 2022 release and it seems that my reports are opening now without a problem but the loading time seems to have increased quite a bit. it takes at least 5min until the report is open.

what is more it also seems that when i am trying to edit the report or just navigate from one page to another or from one measure to another the responsiveness is a lot slower.

AJH
Regular Visitor

@ANTOS @Ailsa-msft Thank you Antos! I confirm that also the issue I was having has been fixed in the new December 2022 version. In my case, there is no slowness in opening the reports (or navigating between pages) as Antons describes. Antos: Have you tried to save the opened report? There seems to be a small difference in the file size compared to the version saved with September version - so I am just speculating but saving might help on the performance. Otherwise, I suggest that you contact Microsoft support on the performance issue while it seems that it slowness could be related to this fixed issue in opening files.

I will now contact to Microsoft support to inform that my issue has been fixed.
Br Ari

Ailsa-msft
Community Support
Status changed to: Delivered

Hi @AJH 

I am so glad to hear that your issue has been fixed . Thanks for your reply .

 

Best Regards,
Community Support Team _ Ailsa Tao

AJH
Regular Visitor

@ANTOS Hi! One more idea for performance problems: refreshing the model could possibly help. Br Ari