cancel
Showing results for 
Search instead for 
Did you mean: 

Issues on connection between Power BI and Azure SQL Database using VNet service endpoints

Hi, I'm facing an issue on trying to connect Power BI to Azure SQL Server with Private endpoint activate and public access disable.

After creating an virtual network gateway on Power Platform I could access Azure SQL Server on Power BI DataFlow creation with no issues. However, after saving data flow creation and confim first execution, system displayed "Execution for On-Prem data source failed because it's not registered on a gateway (218884)" message.

 

Could someone help me to identify the solution for that issue?

Status: Investigating

Hi @marcosdp,

 

If you directly register your Azure SQL data source to your VNet gateway, will you see any error? Please create and save your dataflow after you register successfully there.

 

Best Regards,    

Community Support Team _ Caiyun

Comments
v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @marcosdp,

 

If you directly register your Azure SQL data source to your VNet gateway, will you see any error? Please create and save your dataflow after you register successfully there.

 

Best Regards,    

Community Support Team _ Caiyun

marcosdp
Regular Visitor

Hi @v-cazheng-msft,

 

I've followed all the steps related to this documentation https://www.datahai.co.uk/power-bi/connecting-power-bi-to-azure-sql-database-using-private-endpoints... 

 

1. Look at bellow that Virtual Network data gateway is online.

marcosdp_0-1660655954702.png

2. At the first moment, I can access sql server table with no issues. I'm not sure the reason that Data Gateway option on Project Options has no content to select.

marcosdp_1-1660660556369.png

3. The problem starts when I click on Refresh now.

marcosdp_2-1660660764248.png

marcosdp_3-1660660834140.png

Execution fails with "Error: Execution for On-Prem data source failed because it's not registered on a gateway (218884). Additional details: . Param1 = 218884.Param2 = Request ID: xxxx" message

marcosdp_4-1660660864505.png

 

4. When I edit data flow again, systems ask for credentials as lost it.

marcosdp_5-1660661060482.png

So, I inform credentials again just to return to the same point as step 2

marcosdp_0-1660661788274.png

 

 

Any idea?

 

Best Regards