cancel
Showing results for 
Search instead for 
Did you mean: 

Issues connecting to Azure Database for PostgreSQL from PowerBI

My company has production dashboards that have been effected by some issue between Azure Postgresql PaaS service and PowerBI. Any updates on the fix timeline? 


Processing error
An error happened while reading data from the provider: 'Could not load file or assembly 'System.Runtime.CompilerServices.Unsafe, Version=4.0.4.1, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)'

Status: New
Comments
gustavo-nievas
Regular Visitor

Same issue here !!!!!!

 

 

Aweptimum
Helper II

Same issue as well, every report I have set to refresh daily emailed me this error today.

plucky
Regular Visitor

We are also having this issue and unable to refresh reports to our AZURE Postgres database.

dklem
New Member

Same problem here too.

kppinky
Regular Visitor

Here are other issues referencing the same error:

https://community.powerbi.com/t5/Issues/Error-refreshing-data-from-Postgres-for-azure-Could-not-load...

 

https://community.powerbi.com/t5/Issues/Recieved-Could-not-load-file-or-assembly-System-Runtime/idi-...

 

@andyclap mentions:

 

Quick update from MS - looks like they've escalated it as before.


Prajitha Palan RE: - TrackingID#2108260050000920

 

This is to inform you that we have raised an internal ticket to our product team and they are currently investigating this issue.

We will inform you as soon as we receive an update from them.

Thank you for your cooperation.

Regards,
Prajitha​

wjmazzanti
New Member

We are experiencing same issue here.  Affecting all production reporting.  How can we be notified about status of:  TrackingID#2108260050000920 ?  

James

ysanabria
Frequent Visitor

Same issue here

 

Processing error: An error happened while reading data from the provider: 'Could not load file or assembly 'System.Runtime.CompilerServices.Unsafe, Version=4.0.4.1, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)'
Cluster URI: WABI-US-EAST2-B-PRIMARY-redirect.analysis.windows.net
Activity ID: 19ed3808-87e7-476a-9060-a19b48d29b4a
Request ID: ecbbc9fc-e8af-a125-d23d-3661acbd0760
Time: 2021-08-26 20:18:16Z

ctd_bi
New Member

The problem only happens in online version for me. Schedule update only. If I do mannualy in desktop bi it works. Has no solution yet?

v-yingjl
Community Support

Still waiting for the feedback of the ICM(257979704) from the above simliar issue, would update here if there is any progress.

 

Best Regards,
Community Support Team _ Yingjie Li

ALWI
Frequent Visitor

same issue here!