cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with SharePoint.Files in Power Query

When you use [ApiVersion = 15] as an argument in SharePoint.Files in Power Query and the locale is not US, then you get errors like below:

error.PNG

 

There is no issue when you use [ApiVersion = 14], but what's the point of reverting back to old version?

 

Just to be clear, I'm in Australia, and we're using the DMY date format. I'm not doing any transformations -- I am getting those errors right after I connect to SharePoint (there's no step that transforms data types). I have not checked whether other SharePoint.* functions are affected -- have no interest in that.

Status: New
Comments
Community Support

Hi @DMM

 

I tested in Power BI desktop version 2.79.5768.1082 64-bit (March 2020) but not able to reproduce the issue. Please run the same desktop version as ours then test again. 

 

q2.PNG

 

Best Regards,
Qiuyun Yu

Frequent Visitor

@v-qiuyu-msft Unfortunately, that doesn't help.

 

I tried setting the locale of SharePoint to English (United States) and English (Australia) (not Austria) -- didn't help.

 

My Power BI application language is Windows default, and Windows language is English (United States). I tried setting Power BI application language explicitly to English (United States), that didn't help either. There's no option to set it to English (Australia) or similar, as far as I see.

 

A few people have kudoed my post -- clearly there must be some issue.

Community Support

Hi @DMM

 

I would suggest you create a support ticket to let engineers look into the issue on your side. 

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu