cancel
Showing results for 
Search instead for 
Did you mean: 

Issue in Total Label

I have enabled Total label for stacked bar chart.

Fow few cases it shows the totals and for some it doesn't.

TotalLabel.JPGTotalLabel1.JPGTotalLabel2.JPG

Status: New
Comments
Community Support

hi  @Deemo 

I have tested on my side, it works well.

try to set the label formatting as below:

2.JPG

 

and if possible, please share your sample pbix file for us have a test.

 

Regards,

Lin

Helper II

Hi @v-lili6-msft 

I am talking about Total labels. Formatting is same.

TotalLabel setting.JPG

 

Community Support

hi  @Deemo 

My careless, for total label in stacked bar chart, this is a new feature in power bi.

If your chart has a field in the Legend (for stacked bar/column) or Column Series (for combo) field well, you can enable total labels in its card in the formatting pane

https://powerbi.microsoft.com/en-us/blog/power-bi-september-2020-feature-summary/#Total_labels_stack...

 

and i have researched it again, it seems that when filter legend field to show only one value in legend, then total label will not available.

so i would suggset you enable data lable too.

Not sure if this can be considered as an issue or default designed, you may submit your idea here to help power bi improve.

 

 

Regards,

Lin

Helper II

Thanks for your reply @v-lili6-msft . Shouldn't it be treated as a defect? I read the blog, nowhere it is mentioned that it will not work if we have just one legend.

Community Support

hi  @Deemo 

I have submitted this to PG, ICM:209655126 

will update here once I get any information.

 

Regards,

Lin

Community Support

hi @Deemo 

I get this from PG team:

Yes, it is by design. We are reconsidering removing the limitation, but if user wants "total" outside end, just set the regular data labels to outside-end as well.

 

Regards,

Lin

Helper II

Thanks @v-lili6-msft . I don't see "Outside-end" option in data labels and I am using September 2020 version.

Deemo_0-1603176777876.png

 

Community Support

HI  @Deemo 

Usually, when you put a field into Legend, "Outside-end" option will not in data labels.

and I know a workaround, could remove filed from Legend, then set "Outside-end" option in data labels, now put filed into Legend again.

 

Regards,

Lin

Helper II

It didn't work for me. After putting legend again, it is resetting the position to "Auto"

Community Support

hi @Deemo 

First, this just is a workaround for your requirement.

Second, in formatting pane, after putting legend again, it is resetting the position to "Auto", but in the visual, this will work as "Outside-end" when you filter legend field to one value.

 

 

Regards,

Lin