cancel
Showing results for 
Search instead for 
Did you mean: 

Issue: Unable to use Power BI Service as a source in PBID when user is only member of the workspace

We encounterd several issues since a while when users have created Power BI Desktop reports based on Power BI service data sources.

 

1. When a user a PBID report has made with a Power BI Service as a source they cannot re-open the PBIX. Power BI gives a proxy error. That is strange because the have made a connection with the power bi service when the made the report. When we first open Power BI Desktop en sign in with the account and then go to Open PBIX from file, the file loads succesfull in Power BI Desktop and everything works.

 

2. When a user is only member of the workspace where the Power BI service data set lives he cannot see the power bi service data set with Power BI Desktop. When we give the user admin rights (instead of Member) in het Power BI Workspace where the data set lives the user can use the data set in Power BI Desktop. In previous versions of Power BI Desktop this worked as described in "https://docs.microsoft.com/nl-nl/power-bi/desktop-report-lifecycle-datasets" but now we need to give the user admin rights in the workspace before he can use the Power BI service datasets....

 

could you check these issues with the Power BI service data sets in combination with Power BI Desktop?! In the Power BI service everything works great, it only happens in Power BI Desktop.

Status: Needs Info
Comments
Moderator

@VoldaPBI19 ,

I am unable to reproduce the above issues. What is your Power BI Desktop version? Please update to latest version of Power BI Desktop(2.66.5376.2161).

For the second issue, users who have edit permissions on the app workspaces are able to see the power bi service data set with Power BI Desktop, users don't have to be admin.
1.PNG

Regards,
Lydia

Moderator
Status changed to: Needs Info
 
New Member

Thanks for the reply and i think the second issue is solved by changing the option that users have edit permissions. Thanks for that one!

 

The first issue is still a problem. We can work around this by first opening PBID but it should also work when opening it from the PBIX file. I've downloaded the latest version "Versie: 2.66.5376.2161 64-bit (februari 2019)" and we still have the problem....

 

I will check this problem on another laptop this weekend outside the organisation domain/network and will post the results....