cancel
Showing results for 
Search instead for 
Did you mean: 

Inconsistent CSV Import when Data Detection Disabled

I have automatic data type detection disabled for unstructured data sources. Yet when I go to import a CSV file, this is how the UI looks:

edhans_0-1597714267845.png

  1. It should be set to "do not detect data type" (3rd choice in the drop down)
  2. If I have it set to detect based on first 200 rows, or entire data set, then it should, even if I have the overall option turned off. Either that, or these options should not be shown on this dialog box. Leaving it set as is it will not detect data types, which is misleading.

August 2020 desktop.

 

Status: New
Comments
Community Support

@edhans 

 

You may share feedback via Ideas to help improve Power BI.

Super User III

Hi @v-chuncz-msft - this seems to be a bug to me. If it says "Based on first 200 rows" should it not do that? Instead, the setting in options overrides, but doesn't indicate that. I'm not asking for a new feature, just that all places in Power BI desktop work consistently with the new "do not detect data type" option.

If you think this is not a bug, but is operating as designed, and should be an idea, please let me know.