cancel
Showing results for 
Search instead for 
Did you mean: 

[Help Needed - BUG] PBI Data View not letting me filter on the column I selected

Dear PBI Community, 

Issue - PBI Data View not letting me filter on the column I selected, it jumps to a random column/dimension instead. 

I.e. Select Column I want to filter, click on the down arrow on the column >>> Instead of seeing the drop down, it takes me to a random column in the dataset. 

I have tried all basic troubleshooting, even recreating the column, and even reinstalling PBI Desktop itself. 

As you can imagine, this is incredibly frustrating and tiresome. 

This is happening across multiple workbooks/ columns, not just one column. 

Any help would be greatly appreciated. 

 

Thank you,

AL 

 

Status: Accepted

Hi @alim8,

 

Issue has been reported internally(ICM 328143236). Will sync here once there is any update.

 

Best Regards,                                                  

Community Support Team _ Caiyun

Comments
than688
Frequent Visitor

I am also having this exact issue.

 

Also, a key column in my dataset is not populating correctly (even though the query editor shows correct values, when loaded it does not) which means my company's financial reports are out of action in the middle of month-end. I have a suspicion the two issues are connected.

twintrbl
Advocate I

YES - I have the same problem. Also, if I pick a date column, it doesn't allow me to filter it as a date (with an "on or before", "on or after" etc. type of filter. I only see a pick list of dates to select or deselect. And it only includes the dates that actually have records).  Same thing with number columns - only a list of values from records, with no options for greater than, less than, etc.

 

Does anyone else have that too? Or is it just me?

 

BrunoMedrano
New Member

The same is happening to me #PowerBI please fix this bug. When I try to filter a column, another column is selected instead and I cannot work properly. Already re installed BI but didnt work. 

MAYOD
Regular Visitor
AntonioCS
New Member

I have the same problem since 20 hours ago. 😕

alim8
Advocate I

https://community.powerbi.com/t5/Desktop/I-can-t-use-Filters-in-DATOs-view/m-p/2701584#M944954

 

There is another thread above, another user indicated issue started around the same time. 

I started experiencing this issue last Friday, located in ANZ timezone. 😞 

 

Thank you,

AL 

v-cazheng-msft
Community Support
Status changed to: Accepted

Hi @alim8,

 

Issue has been reported internally(ICM 328143236). Will sync here once there is any update.

 

Best Regards,                                                  

Community Support Team _ Caiyun

MAYOD
Regular Visitor

Please make sure you're considering https://community.powerbi.com/t5/Issues/Filter-problem-in-Data-View/idi-p/2698528 within scope for this issue, as they appear to be related display issues with data view that occurred at the same time.

DaveJoe1000
Regular Visitor

This is also happening to me, really maddening.

HenW
Regular Visitor

Having the exact same issue and it is infuriating.