cancel
Showing results for 
Search instead for 
Did you mean: 

'Header always displayed' setting not working in Report Builder

I'm building a report with a single tablix that displays a few hundred rows. Part of the requirements are to keep the header visible while the user is scrolling through the data (via the Power BI service). There is a setting available for exactly that:

justin0123_0-1638312848506.png

The report is fairly sensitive so I can't share the layout without redacting it into uselessness, but it was created from the report table wizard and only contains a text box for a title and a tablix that was generated by the wizard.

 

Even though this setting is active, the header scrolls offscreen both in the report builder and on the Power BI service. I've also tried turning on repeat headers on each page (and done the same with rows) and still the header disappears when the results are scrolled.

 

I've also tried printing the report, the header was only on the first page, I've also tried to group rows so I can force a page break and while the break was successful, the header still did not show on subsequent pages.

 

Any ideas on what I might be doing wrong?

 

Status: Investigating

Could not reproduce it in my side as far as my test.

Which version of Power BI Report Builder you have used and whether consider providing some screenshots about this issue for the headers without any sentive information.

 

Best Regards,
Community Support Team _ Yingjie Li

 

 

 

Comments
v-yingjl
Community Support
Status changed to: Investigating

Could not reproduce it in my side as far as my test.

Which version of Power BI Report Builder you have used and whether consider providing some screenshots about this issue for the headers without any sentive information.

 

Best Regards,
Community Support Team _ Yingjie Li

 

 

 

Anonymous
Not applicable

Thanks for your response and apologies for the delay in getting back. I've created a new report using some non-sensitive data. If it makes any difference, this data came from an ODBC data source (Azure databricks) the original report uses a Powre BI dataset. The result is the same either way.

 

This is the report definition, generated from the table wizard:

justin0123_0-1638745964530.png

I have 'Keep header visible while scrolling' turned on:

justin0123_1-1638746005940.png

However, when running, the header scrolls offscreen:

Before scrolling

justin0123_2-1638746069666.png

After scrolling:

justin0123_3-1638746087809.png

The same thing happens in Power BI service (not shown as the data source is not set up for remote access)

Report builder version is most recent, auto updates are on:

justin0123_4-1638746362906.png