cancel
Showing results for 
Search instead for 
Did you mean: 

Guest B2B users see "Your Power BI session expired" after 15m, redirected to home tenant/signup page

Approximately 15 minutes after logging in to access the Power BI apps in our tenant (the inviting tenant), our external/guest B2B users see a "Your Power BI session expired" prompt, and are then redirected away from our Power BI tenant and are unable to navigate back. 

 

Where the user is redirected varies based on the user licensing scenario (note: all of our external/guest B2B users have a Power BI Pro license directly assigned to them in our tenant):  

 

1. Users that have a free Power BI license in their home tenant are redirected to their home Power BI tenant site/workspace.

2. Users that DO NOT have a free Power BI license in their home tenant are instead redirected to the Power BI signup page.

 

Other notes: 1. This seems to be occurring across all browsers. 2. Users are able to re-gain access to our Power BI resources only after signing out and back in, however, their sessions are always limited to 15 minutes. I have confirmed this affects external/guest users of ours from multiple tenants.

Status: New
Comments
Community Support

@ChrisA ,

 

Please trying add external users in admin portal before you share the app with them and try again. In addtion, does this issue occur in a classic app workspace or new app workspace? 

 

Regards,

Jimmy Tao

Regular Visitor

@v-yuta-msft  Our organization is experiencing the same issue. Our guest users are all added to Azure active directory groups and they are granted permissions to apps. We work with new workspaces. Any help would be appreciated as this is very inconvenient for our end users. 

Regular Visitor

@solka-102 , thank you! I was starting to think we were the only ones. 

 

@v-yuta-msft, all of our external users were added in the admin portal prior to having an app shared with them. We use the "Planned Invites" approach to adding guests as described in Power BI Azure B2B whitepaper and grant access to apps using security groups. 

 

All of our workspacesa are "new", about half of which were migrated from classic. 

New Member

We are also experiencing the same.

Regular Visitor

Thanks, @carmenbarrett .

 

Update: Created support ticket about 30 hours ago. Received an update an hour and half ago (~1030 CST) from the support engineer that "we are working on the issue". 

Frequent Visitor

We are experiencing the same also.

Regular Visitor

My organization is also experiencing this issue and opened a ticket with Microsoft. 

 

Meeting later to get a trace file in the hopes Microsoft can analyze and determine what's causing the issue.

Frequent Visitor

Same issue. We set up a support ticket and we sent in pictures and did a trace. Fingers crossed! 🤞

Regular Visitor

We are experience a similar issue - will log a support ticket shortly.

Regular Visitor

Microsoft Support asked us to re-check status on our end, and initial testing so far suggets the issue has been resolved, at least in our tenant (North Central US).