cancel
Showing results for 
Search instead for 
Did you mean: 

Google Analytics Connector in PowerBI Desktop

I've recently installed November update for PowerBI Desktop and the Google Analytics connector has stopped working.

Am getting error message "Unexpected error: Collection was modified; enumeration operation may not execute."

Any advice?

Status: New
Comments
Visitor

 @PrestaPower and @v-qiuyu-msft I have the same problem. 

 

Is there any other workaround for this issue?

Visitor

The only workaround is to remove the credentials as WillHopkins menioned and re-add them, but you'll have to do this everytime you refresh your data.

 

Hopefully someone has sent the trace over so they can investigate and fix it.

Visitor

@v-qiuyu-msft - I have done what you asked and installed and run Fiddler when reproducing the error.

 

I've sent you a PM with the trace report - hope it help you getting our problem solved!

Visitor

Just another thing, @v-qiuyu-msft.

Since I've had the same problem happening to me yesterday, I've configured (yesterday) the data gateway with my Power BI desktop file and set the credentials for google analytics to test scheduled refresh for 9h30m GMT-2 (Power BI Free):

   > the data was successfully updated Today after 15 minutes (Brazilian Portuguese):
Atualização PBI.PNG

   > after an hour the website where the report was published got the updated data.

   > and all of this happened with Power BI Desktop presenting this problem yet again this morning (after updating the Google Analytics credentials yesterday as @WillHopkins recommended)

   > so it seems the connection problem only happens on the desktop client.

Hope these informations help you out!

Moderator

Hi all, 

 

Please share fiddler trace and desktop trace log with us as I mentioned before, so we can try to investigate the issue further. 

 

@Tukas Already replied via private message. 

 

Best Regards,
Qiuyun Yu 

Visitor

Hi @v-qiuyu-msft

 

Can you please describe the steps I need to follow to create the logs you need?

 

This issue is challenging my workflows to the point where I may need to downgrade to the previous Power BI version unless a solution is found soon. But I haven't done any troubleshooting of this sort before, so I'd like to know how I should proceed.

 

Thanks.

Visitor

@rthomsen, the trace has already been sent so we're all playing the waiting game now.

Moderator

Hi all, 

 

The issue has been reported internally: CRI 93390259. Will keep you update once I get any information. 

 

Best Regards,
Qiuyun Yu 

Moderator

Hi all, 

 

The fix will be available in Power BI desktop December version. 

 

Please try @WillHopkins's workaround (clear credential for Google Analytics) currently. 

 

Best Regards,
Qiuyun Yu 

Visitor

 

That's great news!

The workaround works fine for the time being, and I'm glad to hear this will be fixed in the near future. Thanks for the update.