Google Analytics Connector in PowerBI Desktop

Status: New
by Andy4581 Visitor on ‎11-14-2018 08:43 AM

I've recently installed November update for PowerBI Desktop and the Google Analytics connector has stopped working.

Am getting error message "Unexpected error: Collection was modified; enumeration operation may not execute."

Any advice?

by RD9 New Member
on ‎11-14-2018 01:49 PM

Heya, I'm having the exact same issue.

by Moderator v-qiuyu-msft
‎11-14-2018 06:47 PM - edited ‎11-14-2018 11:21 PM

Hi all, 


I'm not reproduce the issue in Power BI desktop November version. Please run fiddler with below option enabled, then repeat steps to reproduce the issue, save all sessions to .saz file, upload it to your OneDrive or dropbox, send the share link to me via private message. 




Best Regards,
Qiuyun Yu 

by Caspar Occasional Visitor
on ‎11-15-2018 12:37 AM

Hi, just to add, i'm also seeing the same issue.  I can't retrieve any information from our Google Analytics Account. SQL is still fine.

by MaxPhilipp New Member
on ‎11-15-2018 05:44 AM

Same thing for me. Dashboards which are live are updating well, but on pbi desktop i cannot refresh without warning /cannot work at all with GA data

by staylor Occasional Visitor
‎11-15-2018 06:27 AM - edited ‎11-15-2018 08:18 AM

I'm having the same problem, worked before yesterday without a problem. I have the November 2018 Power BI version.

by LeeWitten Visitor
on ‎11-15-2018 06:55 AM

Worked fine this morning - did the update and same as everyone else, no longer works.

by jdugre Frequent Visitor
on ‎11-15-2018 07:24 AM

Same issue here

by Nikitas10 Regular Visitor
on ‎11-15-2018 09:09 AM

Doesn't work anymore... Can't pull GA data either

by WillHopkins New Member
on ‎11-15-2018 10:57 AM

Hi I had the same issue after the Nov update. I went to file > options and settings > data source settings and removed the GA credentials. This forced a re-authentication with GA and everything then worked. 

by staylor Occasional Visitor
on ‎11-15-2018 11:24 AM

Thank you WillHopkins, that worked for me as well.

Idea Statuses