cancel
Showing results for 
Search instead for 
Did you mean: 

Gateway - Refresh Problem

Hello Guys,

 

I'm facing a huge problem about refreshing my dashboards on the app.powerbi. The gateway system is not working well and he is showing the follow screen:

 

Data source error{"error":{"code":"DM_GWPipeline_Gateway_InvalidConnectionCredentials","pbi.error":{"code":"DM_GWPipeline_Gateway_InvalidConnectionCredentials","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"The credentials provided for the MySql source are invalid. (Source at {myip};{mydataset}.)"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.CredentialError.DataSourceKind","detail":{"type":1,"value":"MySql"}},{"code":"Microsoft.Data.Mashup.CredentialError.DataSourcePath","detail":{"type":1,"value":"{myip};{mydataset}"}},{"code":"Microsoft.Data.Mashup.CredentialError.Reason","detail":{"type":1,"value":"AccessUnauthorized"}},{"code":"Microsoft.Data.Mashup.MashupSecurityException.DataSources","detail":{"type":1,"value":"[{\"kind\":\"MySql\",\"path\":\"{myip};{mydataset}\"}]"}},{"code":"Microsoft.Data.Mashup.MashupSecurityException.Reason","detail":{"type":1,"value":"AccessUnauthorized"}}],"exceptionCulprit":1}}} Table: {mytable}.
Cluster URIWABI-BRAZIL-SOUTH-B-PRIMARY-redirect.analysis.windows.net
Activity IDaa5db203-4ab4-4d01-babb-797232d210f6
Request IDe4df98e9-9a18-fe52-ad70-fa6cb2b4f567
Time2020-03-23 13:33:21Z

 

Which is wierd because I can refresh on my power BI desktop with no problem.

 
 
Status: New
Comments
Regular Visitor

I am having this error as well when I try to refresh my datasets. Maybe a Microsoft issue? My PBI Desktop keeps freezing when a file is open, having to force close. Not sure if this is related. I will let you know if I find anything out on my end.

Regular Visitor

Yes I have the same problem since yesterday. Looks like it has something to do with the credentials but I didn't change anything so it's weird for Power Bi to say that the credentials are invalid. It was updating fine before. Also, some of my reports using the same credentials are updating normally.

New Member

Well, to solve te issue I had to reinstall and I created another gateway name. I hope it help you guys as well.

Frequent Visitor

I have a similar issue, same pbix file, working fine on the service, and working fine on the desktop. As soon as I change any table relationship in the data model and re-upload, doesn't refresh anymore with credential problems. In the desktop it works no matter what, just not on the service.

When I try to put the relationship as before, re upload, the service doesn't work again with credential problems.

New Member

This problem happened to us suddenly...

 

 

The solution that fixed this for us was to simply reset the recovery keys on the gateway and create new keys. That's it.

 

 

Hope this helps someone!