cancel
Showing results for 
Search instead for 
Did you mean: 
0

Gateway PowerShell module not working after upgrade to 3.2.52

Problem already described by Nicolai J. Schmidt under https://powerbi.microsoft.com/en-us/blog/on-premises-data-gateway-march-2019-update-is-now-available...

 

After upgrading the On-Premises Data Gateway to V3000.2.52 (March 2019) the PowerShell module does not work any more as described under "https://docs.microsoft.com/en-us/power-bi/service-gateway-high-availability-clusters#powershell-supp...".

 

Problem: the Login-OnPremisesDataGateway does not accept the email address (and therefore all other cmdlets do not work also).

Preliminary root casue: changed/wrong configuration inside "Microsoft.PowerBI.DataMovement.GatewayCommon.dll.config".

Workaround: NOT tested yet, but it might work to use the old values (specially the "GlobalServiceEndpoint") inside the above config file (see initial link on top)

Status: Delivered
Comments
Frequent Visitor

Just liked to confirm that in our environment the workaround to use the "old" values seem to work just fine! We replaced the complete applicationSettings section.

Looks like the "new" values are related to some kind of testing/debugging environment not cleaned up for production... (see https://github.com/Microsoft/powerbi-powershell/blob/master/src/Common/Commands.Common.Test/PowerBIS...)

 

Thanks and credits to Nicolai for his troubleshooting!

Community Support Team

Hi @MikeAtUnibz ,

 

Glad to hear that your problem has been resolved. And thanks for your sharing.

 

Best regards,

Yuliana Gu

Community Support Team
Status changed to: Delivered