cancel
Showing results for 
Search instead for 
Did you mean: 

Focus Mode bug with Power BI Embedded Report

With Power BI reports Emdedded in our website we started having and issue with Focus Mode behaviour on all visuals.

 

When clicking on Focus Mode, the selected visual takes the whole page but instead of doing so over a blank background, the original report page remains on the background. So Focus Mode results in the visual appearing over the whole page which is a complete mess.

 

This was not happening before and we haven't done any change to either the report or the website where this report is embedded.

However I cannot reproduce the issue on Power BI service. If I click focus mode on the same report on power bi service this works as expected, I just see the selected visual without having the original page in the background.

 

Is anyone else experiencing similar issue with Focus mode? 

Is there any known change that could explain this issue happening on Embedded or any new requirement for the formatting of embedded websites that could be related to this issue?

 

Status: Delivered

Thanks for the shared workaround.

Comments
v-caitlyn-mstf
Community Support
Status changed to: Accepted

Hi @donquijot ,

 

There is a glitch in the focus mode in Power BI, the fix is scheduled for December, please be patient and I will update you if there is any progress.

 

ICM:344849117

 

 

Best Regards,
Community Support Team _ Caitlyn

 

donquijot
New Member

Hi @v-caitlyn-mstf 

 

Thank you for the feedback on this.  Waiting until December release is not a problem.

In case it helps, I found this seems related to the Embed setting for Transparent Backgroun. See link to docs.

I was able to reproduce the issue on the Power BI Embedded playground by adding this setting.

See image attached. 

 

Adding this setting breaks Focus Mode on embedded on the playground even on the default report.

 

FocusModeIssuePlayground.png

 

My current workaround is to remove the Transparent backgound setting from by emded settings. Of course eventually I would like to be able to go back to using this setting as this was working well in the past.

v-caitlyn-mstf
Community Support
Status changed to: Delivered

Thanks for the shared workaround.

Ann_Forte
Regular Visitor

@v-caitlyn-mstf  Do you have a date for the fix you mentioned above ICM:344849117? 

The workaround doesn't work for us. We have 1400 reports with this issue. 

 

Ann F.