cancel
Showing results for 
Search instead for 
Did you mean: 

Field Parameters - conditional formatting issue

I am using the new Field Parameters feature to allow users to choose the measure(s) to be displayed in a matrix. Adding conditional formatting (e.g. background color) to cells, all the measures that are defined in the Field Parameter can be chosen under ”Series” - great! However, conditional formatting based on ANOTHER measure/series does NOT seem to work… could this be investigated?

Status: Delivered

Hi @MdJ 

Thanks for your reply . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao

Comments
Ailsa-msft
Community Support
Status changed to: Needs Info

Hi @MdJ 

Can you provide your sample with pbix file(remove sensitive info) ?It may help me to deal with your issue easier .

 

Best Regards,
Community Support Team _ Ailsa Tao

TallesLessa
Frequent Visitor

@Ailsa-msft 

Hello I am having the same issue. As seem in the examplo below I have two hightlight options that work by themselves so I created a field parameter to alternate between them dinamically and applied it as the field in the conditional formating option of the third graph.
The title oh the graph updates correctly based on the field parameter selection, however the formatting does not work.
Here goes the sample file 
https://drive.google.com/file/d/1ywez2sUVSp7zqpiBia05mkiCUHR5e8pT/view?usp=sharing

TallesLessa_0-1656500704433.png

Here is the field table created

 

TallesLessa_1-1656500983991.png

 

And seems to me that teh conditional formatting is not accepting the NAMEOF() function as a measure so its treating it as a text in a list ...

TallesLessa_2-1656501199508.png

 

 

 

MdJ
Regular Visitor

Hello @Ailsa-msft,

 

I noticed that the reason the conditional formatting wasn't working properly was because under "Cell elements > Background color > fx", I was accidentally choosing a measure under the group "Format String Measures", which aren't the "real" measures (I think these are generated when applying format strings via calculation items). 

When scrolling a bit further down and choosing the "real" measure, the conditional formatting is actually applied correctly!

So, from my point of view this issue can be closed!

Thanks,

Miel

Ailsa-msft
Community Support
Status changed to: Delivered

Hi @MdJ 

Thanks for your reply . I will change the status to "Delivered" .

 

Best Regards,
Community Support Team _ Ailsa Tao