cancel
Showing results for 
Search instead for 
Did you mean: 
0

Field Parameter used in Donut Chart + single card on "Power BI server"

Hi all, I'm using new field parameter feature as my selection, and use it as value in both "Card" and "Donus Chart".  It works good in PowerBI Desktop/ PowerBI mobile/ Publish to Web but not works property in PowerBI server. (Snapshot as below)

It seems calculate single card first( value is correct) then stop calculating donuts chart( value incorrect).

Does anyone face the same issue or I'm doing something wrong? Thank you.

Picture3.png 

Status: Delivered

Hi @Liyi,

 

Fix for the issue has started to be deployed into product environment region by region and it will be generally available before middle June. Please be patient for the fix. Thanks for your understanding!

 

Best Regards,

Community Support Team _ Caiyun

Comments
v-cazheng-msft
Community Support
Status changed to: Investigating

Hi @Liyi,

 

May I know how you create your Card and Donut Chart? Did you calculate their values by Measures? If it is convenient for you, could you please provide a download link of a sample pbix file that contains this issue so I can investigate on it? Thanks in advance!

 

Best Regards,

Community Support Team _ Caiyun

Liyi
New Member

Hi Caiyun,

Yes I used it based on "measure" (countx, sumx)

I created a small dataset and upload to my workspace, the result is still the same.

Desktop:

Liyi_0-1653100095808.png

 

Power BI server

Liyi_1-1653100121411.png

 

Card value is correct but docut chart looks strange.

PBIX file stored in my personal gdrive, please kindly receive. Thank you.

Sample Data pbix 

 

Best Regards,

Liyi

v-cazheng-msft
Community Support
Status changed to: Accepted

Hi @Liyi,

 

This issue has been reported internally(ICM 309646938). Will sync here once there is any update. Thanks for your understanding!

 

Currently, please try this workaround: refresh your browser page.

 

Best Regards,

Community Support Team _ Caiyun

v-cazheng-msft
Community Support
Status changed to: Delivered

Hi @Liyi,

 

Fix for the issue has started to be deployed into product environment region by region and it will be generally available before middle June. Please be patient for the fix. Thanks for your understanding!

 

Best Regards,

Community Support Team _ Caiyun