Showing results for 
Search instead for 
Did you mean: 

Failed refreshes on reports merging data from on-premises gateway with sharepoint online

Since this monday after upgrade to latest on-premises data gateway version, we get refresh failures on some reports with the following error message: 

      "Unable to connect to the data source undefined."

Those reports were not modified and were working fine before gateway update.

The issue can only be reproduced in a report mixing (ex: with a merge) data from both on-premises source and sharepoint online file.

Reports sourcing both these data without any merge run fine.

We cleared credentials, checked all connections were categorized as "Organizational" as advised on similar error message in other threads, but with no success. 

Refresh is successful via Personal data gateway and when downgrading to previous gateway version, I don't get a successful refresh.

I tried to apply the fix referenced on Power BI support page for some TLS/SSL issue but with no success, and this mention has disappeared from the portal since a few minutes:


Best Regards, 





Status: New
Frequent Visitor

We have the very same issue, since Monday and after updating to the latest version of the Gateway. We also noticed the message that was previously up on the status page is gone, but it is this same error we are getting:



The issue does look ver specific to merging dataflows, as we've tried many different datasources together to recreate the issue but only have a problem when we introduce dataflows and then try refresh via the service. If the dataflos are not merged there is no problem.

Also, it is only an issue on the service, refreshing via desktop works fine.

New Member

tenemos el mismo problema,


desde el lunes no actualizan, informes que tienen meses funcionando.


en desktop si actualizan pero online no



Frequent Visitor

Hello all,


I am also experiencing this issue. In Power BI Desktop, the Dashabord refreshes no problem, but has continually produced Refresh errors when refreshing on the Power BI Service since Nov. 21. 


I have pasted the following message from the Power BI Service below:


"Underlying error code: -2147467259
Underlying error message: The import List.ConformToPageReader matches no exports. Did you miss a module reference?
DM_ErrorDetailNameCode_UnderlyingHResult: -2147467259
Microsoft.Data.Mashup.ValueError.Reason: Expression.Error
Cluster URI:
Activity ID: 99afeb2e-1d78-4586-9a6d-ec3830ee7273
Request ID: 7aa7d47a-84e8-4d75-b444-001aaff591fc
Time: 2020-11-25 21:17:33Z"


Thank you,


Regular Visitor

any answers? 

Frequent Visitor

@amihaim ,


Try re-installing the Power BI Data Gateway and this should solve the issue I faced and could resolve yours as well. Apparently there is an update to the Data Gateway software that requires re-installation on whichever VM it is located on.

Regular Visitor



We are experiencing a similar issue and believe that it is related to the latest gateway update. Since Monday, refreshes have been breaking with our Redshift gateway cluster. We have already tried re-installing the gateway and it didn't help. We have also tried restarting the server.


The error message that we got is included below:


Unable to connect: We encountered an error while trying to connect to . Details: ""Hide detailsActivity ID:    09fac9dc-6570-46e7-b91a-736252c70c76Request ID: c84e5e84-4735-b613-77bc-1bcb9734ee3dCluster URI: code:    400Error Code: DMTS_UpdateClusterDatasourceCredentialsErrorCodeTime:   Tue Dec 01 2020 14:18:30 GMT-0800 (Pacific Standard Time)Service version:    13.0.14788.65Client version: 2011.3.03863-trainWelocalizeGateway02:    Unable to connect to the data source undefined.Underlying error code:  -2147467259Underlying error message:   ODBC: ERROR [IM003] Specified driver could not be loaded due to system error 126: The specified module could not be found. (Simba Amazon Redshift ODBC Driver, C:\Program Files\On-premises data gateway\m\ODBC Drivers\Simba Amazon Redshift ODBC Driver\AmazonRedshiftODBC_sb64.dll).DM_ErrorDetailNameCode_UnderlyingHResult:   -2147467259Microsoft.Data.Mashup.ValueError.DataSourceKind:    AmazonRedshiftMicrosoft.Data.Mashup.ValueError.DataSourcePath:;data_warehouseMicrosoft.Data.Mashup.ValueError.OdbcErrors:    #table({"SQLState", "NativeError", "Message"}, {})Microsoft.Data.Mashup.ValueError.Reason:    DataSource.Error


The error message seems to indicate that this file is missing but we have the file in the correct location.. See snapshot.




Any help is appreciated, thank you.

Frequent Visitor

Hi @anneliesbuck 


We actually started experiencing refresh issues on Nov. 21, 2020. Reinstalling the latest Data Gateway software solved the problem we were experiencing. If your's didn't starting failing till Monday Nov. 30 it might be something else causing your error than the Data Gateway, but since I am unsure of how to solve your issue I digress. I am sorry I cann't help you any further, good luck to you though.


Kind Regards,


Advocate I

Similar issues, even after updating gateway.  Some refresh issues resolved, others not so much.


None of my datasets that connect to dataflows work

Community Support

Hi everyone,


The latest on-premises data gateway has some known issues as well. you may also try Previous monthly updates and create a support ticket for assistance.

Frequent Visitor

I had started another thread with this same issue back on November 20th.  Combined data sets started failing refreshes right after I updated the gateway.  What worked for me is I reverted back to the October version of the gateway and have not had any issues since then.   Make sure you have the Key needed to reinstall your gateway because you're going to have to uninstall and reinstall to go back to the previous version. The key is needed to install the existing gateway back onto your desktop.