Showing results for 
Search instead for 
Did you mean: 

Facet Key - Custom Visual - Does not work on previously created reports

Hello there, we have some published reports using the Facet Key custom visual, however today those visuals are not working in any level (not the PBIX in desktop, neither the ones in our workspaces and not even the ones that we previously published to web).


Here are the things I have tried so far:

- Updating the visual from the marketplace

- Deleting the visuals and create them again

- Activating the "Modern visual header with updating styling options" in the desktop reports

- Saving that previous file with another name and even as a template

- Publishing the report to a workspace, and export it as a PBIX


So far the only way I have found this visual to work again is to create a file from scratch and draw everything again. However since we have lots of reports created and lots of work done in the query editor, data editor and in the report itself, we would like to avoid this solution if another one may be suggested.

I also matched the "Current file options" in the new file with the old ones and still didn't work.


Help would be appreciated.


Status: Accepted
Community Support

Hi @ederfranco,


Would you please share issued pbix file with us? 


Best Regards,
Qiuyun Yu 

Regular Visitor

Hi @v-qiuyu-msft,


Thanks for your response, I can't share the file in the thread, so I sent you a PM with it.


Also, here's an update of the Issue.

Like I said before, when I create a fresh file the visuals seems to work fine, however after saving and reopening the file, the visual stop working again, so in the worst case scenario, that isn't a solution anymore.




Regular Visitor

+1 on this issue, Facet key was working fine for me about a week ago in the desktop client, now it doesn't work in any pbix viewed in the desktop client, but it does work in Power BI Online.


Desktop client viewDesktop client viewPinned Live Page view (Power BI Online)Pinned Live Page view (Power BI Online)Report view (Power BI Online)Report view (Power BI Online)


I also cannot share this PBIX file with you, it contains way too many trade secrets.

Regular Visitor

Add me to the list. Everything worked fine until about two days ago and now I cannot see my Facet Key visuals. I do not want to recreate these reports and cannot share them outside my company. Obviously, something has broken the Facet Key visual recently. Mine look like the screenshots above - just a title and search box. I've tried recreating it in the same report and changing the values to no avail.

Helper III

Same issue here.

Frequent Visitor

same issue

Helper III

Any update on this?  I have a presentation tomorrow and would like to use the Facet Key I showed in pre-meeting screenshots...

Not applicable

Ive been having the same issue since Monday as well. I have also tried recreating the visual, updating it etc. Mine looks like the screenshots above, just a title and search box. Is there any update on a fix yet?

Also dont know if anyone else if having this but the facet count is now also intermittently not working as well, if you try to change the 'initial' and 'increment' values it reverts them back to the default every time, yet if you delete the visual and add it back again it the facet count seems to work. It has only been doing this since the rest of the facet key stopped working. 

Helper III

Had my presentation on Friday and it didn't go well.  Had no easy way to search the dataset.


This is the third time something has gone wrong after an update, so I've made the decision to not schedule presentations near updates, just not worth the hassle.


I checked this morning and Facet Key still isn't working....I'm a paying customer, is there another place I should be posting issues?




Regular Visitor

It seems to be working online, but not in the Desktop version of Power BI. It also works in the iOS app.


So online and iPhone lool OK, but NOT in the Desktop app in Windows 7 Enterprise. This is a change from Friday, where it wasn't working online. I didn't check my phone, so I'm not sure if it worked in the app or not.