cancel
Showing results for 
Search instead for 
Did you mean: 

External Pro License users losing access to reports shared with them.

As of yesterday, External pro licesnse users have lost access to a group they are guest members of. They have lost access to all reports and cannot access them even when using a direct link and the 'share' function within PowerBi Service. This has been reproduced on three different accounts. 

Status: New
Comments
Frequent Visitor

I see that the support site now indicates a resolution by end of day 9 June (when it was previously promised over the weekend). Like many, our clients rely on this to be working. Can we please have a work around or at least some priority around this? Our clients haven't had access to their reports for over a week. 

Frequent Visitor

What I want to know is why this is not being treated as an outage. The Power BI service site says it's "healthy" and this issue is only listed as "information". The environment is at the very least degraded. Perhaps @v-yuta-msft can provide clarification.

Resolver II

I'm wondering why it's not a bigger issue with Microsoft as well. We built a Data-As-A-Service product on Azure/Power BI platform and now none of our users are able to access their visualizations.  I can't understand how Power BI can be marked as "healthy" when such a big issue is occuring.  And why are we not receving more information about why the fix was not deployed last night.

Frequent Visitor

I was told it is marked as "information" because it is affecting specific tenants not clusters. I was told the issue came about because of a conflict between different dependencies in new features that were recently implemented. My tenant is back up now. You should see if you are still having this problem.

Frequent Visitor

My clients started to report on the 8th that it's working now, even though we told them it woudn't be for another day. 

Frequent Visitor

I am having a similar issue.

At around June 2nd SOME of the guest users of a reporting app lost access to it. Now they get the message to upgrade to Pro once they try to access.

However, I can not add them to the Group anymore.

Once I do, it says: Successfully updated - but when I go back to the Permissons Tab, the user disappeared.

😞

All of them are guest user in the AAD. I can see them there and add them. Look like the changes simply don't get saved.

 

Hopefully someone comes up with an idea how to fix this.

Frequent Visitor

We are having the same issue with all embeded links... I think it similar.. 

 

solved..  by adjusting the embed link... which is really dumb... because to fix...MSFT will probably?  switch it back.

 

on the config part.. it used to have %3d%3d at the end of it... if you remove the second %3d... it works again without the popup... 

 

leave it there... access denied or popup saying relogin..

 

Altered Sample of the old embed 

https://app.powerbi.com/reportEmbed?reportId=longCrazyStringhiddenfromyou&autoAuth=true&ctid=longCra...%3D%3D

 

Embed that works now:

https://app.powerbi.com/reportEmbed?reportId=longCrazyStringhiddenfromyou&autoAuth=true&ctid=longCra...

Frequent Visitor

Our org has experienced similar issues. The workaround that has been successful is logging in with your credentials at https://app.powerbi.com/home and then accessing the report via the 'Shared with me menu'.

Regular Visitor

I'm currently having this issue, but with our App that is shared externally. It's been completely stable for the 3 months it's been deployed, but now all external users have lost access to it.

 

Is this the case for others too? Or is this specific to my tenency?

Frequent Visitor

We are now experiencing the issue again with some clients, but not all. I really hope this issue isn't happening again.