cancel
Showing results for 
Search instead for 
Did you mean: 

Export to PDF from Desktop Doesn't Work

Hi, 

 

I tried to export to PDF from my desktop, and nothing happens. I rebooted. Same issue. I had to publish and print from the service in order for this to work. 

 

Version: 2.99.621.0 64-bit (November 2021)

Status: Delivered

There is a newly released November 2021 Power BI Desktop(Version: 2.99.782.0). Issue should be fixed in it.

vcazhengmsft_0-1637913703202.png

 

Comments
Anonymous
Not applicable

I've done all of the steps and well within the limits of export. I have even uninstalled and reinstalled this morning and still it is not working. This is hindering me getting my work done.

cheiden
Microsoft

Hello, I am trying to investigate this issue, could I get some help with the following information?

 

1. When running into this issue, are you running Power BI Desktop from the Microsoft store app or from the MSI?

 

2. If you're running from the MSI, is the preview feature "Power BI Desktop infrastructure update" checked? (File/options and settings/options/preview features)

 

3. Do you have WebView2 runtime installed on your computer? To find this out, open the register editor and look to see if the key "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\Clients\{F3017226-FE2A-4295-8BDF-00C3A9A7E4C5}" exists.  It should have the name of Microsoft Edge WebView2 Runtime.  If yes, what version(pv) is installed? (Should be something similar to 95.0.1020.53).  If that registry key doesn't exist, look for the key "Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\EdgeUpdate\Clients\{F3017226-FE2A-4295-8BDF-00C3A9A7E4C5}" and which version is installed there.

 

Thanks

SQLguy
Advocate I

@cheiden 

  1. Microsoft Store app
  2. Not applicable
  3. I do not have either of the two registry keys you mentioned. In EdgeUpdate\Clients, I have the following two keys:
    1. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\Clients\{F3C4FE00-EFD5-403B-9569-398A20F1BA4A} (Microsoft Edge, version 1.3.153.53)
    2. HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\EdgeUpdate\Clients\{56EB18F8-B008-4CBD-B6D2-8C97FE7E9062} (Microsoft Edge Update, version 95.0.1020.53)
jmcl70
Advocate I

@cheiden 

Hi, in my case I got this issue running Power BI Desktop from the Microsoft store app (The MSI only for Power BI RS)

Just for the record, yesterday my Admin support downgrade me from Nov 2021 to Version: 2.98.1025.0 64-bit (octubre de 2021) for testing and is working fine, so I am going to upgrade using Microsoft Store by myself.

(3 minutes later)

I installed the Nov 2021 version and IS WORKING FINE NOW.

Now I have the October 2021 installed (because I have no admin rights to removed it)

On the Microsoft Edge WebView2 Runtime shows: 95.0.1020.53)

 

 

 

 

cheiden
Microsoft

Hello everyone, we have found the issue and are currently working on getting the fix out to you soon.  Thank you all so much for your help and cooperation!

RVlem
New Member

Same issue here, no respons when trying to export pdf.

jmcl70
Advocate I

To all:

In my case the issue was resolved (I do can export to PDF now)

 

@cheiden mentioned they found the root cause and the solution should comes soon.

In the meantime, to summarize what I did (You may use it as a workaound):

 

1-  Uninstalled the 2.99.621.0 64-bit (November 2021) from MS Store (No need Admin rights)

 

2- IT installed the 2.98.1025.0 64-bit (octubre de 2021) for me (Admin rights required). It can be found here:
Previous monthly updates to Power BI Desktop and the Power BI service - Power BI | Microsoft Docs

The link to the .exe installer will be just above "September 2021 Update (2.97.725.0)"

 

3- I re-installed the 2.99.621.0 64-bit (November 2021) from MS Store (No need Admin rights)
4- Export to PDF IS WORKING FINE

 

Note: I still have the October 2021 installed because I have no admin rights to removed it

 

jmcl70_0-1637506430363.png

edyson
Regular Visitor

Same here. Can't publish from the Desktop and I rely on this. Grrhhh! Please issue a fix pronto.

Thilini
Frequent Visitor

Hi All,

 

We have installed the latest version.

One of our users has this issue while exporting data via excel. I don't see this issue from my side. Also we haven't installed the webviewer2 yet.

 

Looking forward to get this sorted as soon as possible. Thanks

Thilini_0-1637551403259.png

 

dgianni
Frequent Visitor

Hi there @v-cazheng-msft

 

Nothing to do here, still not working at all

In my case, the following conditions are not met on my reports:

 

  • Power BI reports with more than 50 report pages currently can't be exported --> less than 50 pages
  • Reports larger than 500MB currently can't be exported --> Definitely under 500MB
  • The process of exporting the report to PDF might take a few minutes to complete, please try again and wait for a while to see whether you wil get the exported pdf --> The process do not start at all. At the moment it only works with Power BI Online

 

Please check what's going on

 

Thank you