Esri Arcgis Maps does not load on Power BI Desktop for some files

Status: Accepted
by iokoli Frequent Visitor on ‎02-16-2017 03:54 AM

For some reason, on some of my pbix files, the esri arcgis files will not load. I just get the loading screen below






Status: Accepted
by deldersveld Senior Member
on ‎02-16-2017 09:01 PM

Are you able to share a PBIX that where the map does not load, or one of your datasets?

by iokoli Frequent Visitor
on ‎02-17-2017 01:48 AM

@deldersveld, I am unable to share the pbix file as it contains information related to work.



by Moderator v-qiuyu-msft
on ‎02-19-2017 07:05 PM

Hi @iokoli,


Which desktop version did you run? How about running the latest desktop version 2.43.4647.541?


Best Regards,
Qiuyun Yu

by Vicky_Song Established Member
on ‎02-19-2017 07:08 PM
Status changed to: Needs Info
by iokoli Frequent Visitor
on ‎02-20-2017 01:54 AM

@v-qiuyu-msft I am running the latest Desktop Version of Power BI

by iokoli Frequent Visitor
on ‎02-20-2017 02:09 AM

Just for some addedd information, when i start a new Power BI file and create a new esri map. Then I change tabs and  go back to the map, the map does not load.


I have also tried reinstalling Power BI with no success.


Please let me know if you need any further information.

by iokoli Frequent Visitor
on ‎02-20-2017 08:20 AM

 @Vicky_Song What happens now that this is designated as "Needs Info"?

by Moderator v-qiuyu-msft
on ‎02-22-2017 02:12 AM

Hi @iokoli,


Which language version of desktop did you run? Check if this .pbix can load ArcGis map on your side:


Best Regards,
Qiuyun Yu

by edwardkench Visitor
on ‎02-22-2017 12:14 PM

Having the same problem with one workstation. Only get the 3 yellow status bars and "esri" in the background. I updated to latest, uninstalled and reinstalled today, no change. This workstation has been used to build several esri maps in the past without issues.


Also I tried the file out on Dropbox by Qiuyun Yu with the same results. No map.

by thekevinj99 New Member
on ‎02-22-2017 07:26 PM

I am also having the same problem - above PBIX does not load


Thanks in advance


Idea Statuses