0 Kudos

Error while refreshing data for multiples Web REST APIs calls

Status: New
by igormacedo Visitor on ‎05-09-2017 08:02 AM

I'm getting the following error when refreshing my query:

 

Falha na última atualização: Tue May 09 2017 09:58:54 GMT-0300 (E. South America Standard Time) 
Erro durante o processamento de dados no conjunto de dados.

Tipo de fonte de dados:

 

Erro de processamento:

[Unable to combine data] Section1/Query1/AutoRemovedColumns1 is accessing data sources that have privacy levels which cannot be used together. Please rebuild this data combination.

Cluster URI:

WABI-SOUTH-CENTRAL-US-redirect.analysis.windows.net

ID da atividade:

3941fa6a-ebf8-4ba3-b044-cd5a7e755adf

Solicitar ID:

ff48cd7e-f884-e868-8428-c1966b2f3d0a

Hora:

2017-05-09 12:58:54Z

 

I'm consulting two VSTS REST APIs:

- The first one executes a VSTS Workitem Query and returns a json file with the ids of workitems that satisfy the query;

- The second, I execute to get all the data for each id of workitem retrieved from the first api call;

 

I used a similar procedure as described here:

https://blogs.endjin.com/2016/07/querying-the-vsts-work-items-api-directly-from-power-bi/

 

All works fine in Power BI Desktop, the error is only in PowerBI.com.

The privacy option is "None" for all datasources, and I'm using Basic Authentication with a VSTS PAT (Personal Access Token). 

 

I think my issue is equal to this one:

https://community.powerbi.com/t5/Service/Refresh-error-when-combining-multiple-Web-queries/m-p/67897

 

This is the sample code of my model, I built some functions to let it more reusable:

https://gist.github.com/igorguga/40cbf934077bf76b0ba29656ec407d95

 

But I get the error even when I try a simple sample like this https://charlesneedhamcn.wordpress.com/vsts-as-a-powerbi-datasource/.

 

Comments
by v-haibl-msft Super Contributor
on ‎05-10-2017 10:41 PM

@igormacedo

 

I noticed that there was a similar issue reported to the product team before, and some engineers are still looking into it. I'll keep an eye on it and provide info to you if there is any solution for it.

 

Best Regards,
Herbert

by igormacedo Visitor
on ‎05-12-2017 03:48 AM

Thank you, @v-haibl-msft. I'm waiting anxious for a positive solution. 

by v-haibl-msft Super Contributor
on ‎05-17-2017 06:47 PM

@igormacedo

 

Do you use on-premises gateway or personal gateway in this scenario?

 

Best Regards,
Herbert

by igormacedo Visitor
on ‎05-17-2017 08:03 PM

No, any type of gateway. The endpoints are published to the internet through https. 

 

I tested the same code using a VSTS subscription instead of my on-prem TFS, and I got the same issue.

Although, for VSTS, I also tested the code using VSTS.Content instead of Web.Content, and it worked!

I'm wondering what Is the difference between VSTS.Content and WEB.Content... I noticed VSTS.Content uses OAuth to authenticate with VSTS. Is this the point? 

Idea Statuses