cancel
Showing results for 
Search instead for 
Did you mean: 

Error when updating composite model credentials to another Power BI Dataset

Hi All,

Starting today we are experiencing issues when updating the credentials for a Power BI dataset in a composite model. When we try to re-enter the credentials we get the following error:

Failed to update data source credentials: AnalysisServices: Failed to resolve the core XMLA server

This only seems to happen when we publish a new dataset or try to re-enter the credentials on a published (composite) dataset which connects to an existing Power BI dataset (through the API endpoint). See below screenshot:

Fenalytics_1-1663174780291.png


Furthermore I'm experiencing this issue on multiple Power BI tenants in the Western Europe region, there seems to be a change in the Service which I can't get my hands to.

Can anyone confirm this is a bug in the Power BI service so that we can get a fix from Microsoft?

Thanks in advance!

Kind regards,

Ron Verhoeven

 

Status: Investigating

Hi @Fenalytics,

 

We don’t see any statement or known issue said that it’s a bug. If this issue is urgent for you, you could consider submitting a support ticket in Power BI Support if you are a Pro user. Then, there will be a support engineer to help you troubleshoot on this issue.

The link of Power BI Support: Support | Microsoft Power BI

For how to create a support ticket, please refer to How to create a support ticket in Power BI - Microsoft Power BI Community

 

Best Regards,    

Community Support Team _ Caiyun

Comments
MBurban
Regular Visitor

@EbyEaso 

Nope it was the cross near the source and the "xmla" error message indicated at the beginning of the thread when I tried to update the credentials, but this morning (I'm in France, so this is morning 🙂 ) it's working, no more error messages !

 

EbyEaso
Helper III

@MBurban Greaty. Thats good. hope issue is resolved and everyone is good.

pat____
Regular Visitor

I still have the issue in the desktop app, when integrating fields from my DirectQuery dataset (another PowerBI dataset) - it throws an error as soon as a field is added.

Sorry, your credentials could not be authenticated: "Credentials are missing.".  You will not be permitted access until your credentials can be verified.

PBI Desktop App updates may be delayed in rolling out within my organization, could this be the issue?

I'm on version 2.106.582.0 64-bit (June 2022)

 

EbyEaso
Helper III

@pat____  it could be cause related to the credentials you have provided, or the network error.

 

Also try to update the Power BI dektop version and see. 

 

Current version is Version: 2.109.844.0 64-bit (September 2022)

 

Power BI Desktop—Interactive Reports | Microsoft Power BI

Gui_Sajonc
Regular Visitor

Também estou com dificuldades utilizando o Graph Microsoft, mesmo eu tendo o acesso adm e dando permissões.
The credentials provided for the Web source are invalid. (Source at https://graph.microsoft.com/v1.0/planner/plans/
Cluster URI: WABI-BRAZIL-SOUTH-B-PRIMARY-redirect.analysis.windows.net ID da atividade: ac3f75eb-0986-4539-b0be-ad71a8400783 Solicitar ID: 7b3f5beb-c930-e7f6-d6bc-a5b695155394 Hora: 2022-10-25 11:40:38Z

Irasa
Regular Visitor

Is this issue resolved ? 

EbyEaso
Helper III

@Irasa 

Yes, Issue is resolved already. Microsoft Power Bi team has resolved it. I have just created a new report with composite datasets this morning. It works fine.