cancel
Showing results for 
Search instead for 
Did you mean: 

Error: "We couldn't sign you in. Please try again" when trying to sign in on Safari

The attempt to sign in into Power BI on Safari always ends up with following error:

We couldn't sign you in. Please try again

 

I enter my username and password normally. Then the browser seems to follow the endless loop of redirections and finally lands on the sign-in page again with the message "We couldn't sign you in. Please try again"

 

The issue also occurs, when I successfully login to the portal.office.com and click on the Power BI icon.

 

I have cleared cache, history, cookies. It did not help.

 

My configuration:

MacOS 10.14.6

Safari 13.0.1

 

When I do the same with Firefox, it works normally. The same issue is happening also to my colleagues.

Status: New
Comments
Moderator

Hi @andrej_sramko

 

I don't have Mac computer to test it currently. But I test Safari browser 13.1.2 in iPhone. it's able to sign in Power BI service successfully. I would suggest you update your Safari browser then test again. 

 

Best Regards,
Qiuyun Yu 

New Member

All,

This issue is not browser specific. This can happen with any browser you use, and then you have to switch, or use another browser. I've tried multiple ways of clearing cache, resetting to factory specs on Edge, and Chrome and still have to have a 3rd party browser. I am a tech looking for an answer. It appears that this issue also happens with Office 365 EAC (on my machine). I just fixed a BI report issue with the exact same error by asking the user to login using Edge. He was using Chrome as his default browser. I have also tried upgrading his Windows 10 to 1909, but still get the error. This appears to be a problem with clearing login data in the C;\appdata\Roaming (unsure if it is Roaming or Local) data store. 

 

Just a heads up...

Thank you,

Neil Stephens 

Moderator

Hi @Instepcco

 

I would suggest you create a support ticket to let engineers look into the issue on your side. 

 

Support Ticket.gif

 

Best Regards,
Qiuyun Yu

New Member

Same issue - just got in using Chrome. (using safari on MacBook Pro previously)

Frequent Visitor

@v-qiuyu-msft I was contacted by Microsoft support. They couldn't figure out what was the problem. My Safari is up to date. Cache cleared, signed out. I tried everything they suggested. No success 😕

New Member

Hello, 

I also have a few users that have Mac's that are experiencing the same issue, works fine on Firefox, iPad and iPhone but not on the laptop. It's hit and miss on some users with the Mac's..

 

Mac High Sierra 10.13.6

Safari 13.0.3

Cleared cookies, temp files etc like the rest. 

Occasional Visitor

Same issue.  Safari works for logging into office.com and all MSFT apps but PowerBI.  Tried direct to powerbi.microsoft.com with the same result.  Brower seems to cycle meaning progress bar advances and then starts again several times without success at which point I get sent back to Pick An Account with a "We couldn't sign you in. Please try again." error message.  

 

It happened 1 week ago after changing my work network password.  Just odd it PW change worked for every other resource/service except for PowerBI...

 

Cleared cache, history, no obvious keychains, etc.

Chrome and my iOS app work great.

 

Safari 13.0.3

Mojave 10.14.6

 

Ideas?

Moderator

Hi all, 

 

There is a known issue listed in Support site about using older browser to sign in Power BI service: 

 

q1.PNG

 

If the browser is the latest version but the issue still occurs, I would suggest you create a support ticket to get help as mentioned in my previous post. 

 

Best Regards,
Qiuyun Yu 

Occasional Visitor

Same here. Is Microsoft bothered at all?! It's not just Power BI either. I have users reporting this issue trying to log into Outlook on the Web, Calendar and all sorts. They fire up a browser, in my case, it's Safari initially, then go to the office.com page, they can log in fine and get presented with the office apps. On clicking the "Calendar" there is, as described in many of these posts, a cycling of the progress line under the address bar, then the "Pick an account" dialogue with the "We couldn't sign you in. Please try again." message in red just under the "Pick an account title".

The fact that it's fine when you try another browser leads me to believe the issue is with MS holding some aspect of the browser session open on their end.

Visitor

Go to finder and type in Keychain Access


In the search box in the top right, type in Microsoft

 

Select All Items and delete all the items listed.

 

Then quit Safari and try logging in again.

 

@coldry Let me know if you already tried this or if this works