Showing results for 
Search instead for 
Did you mean: 

Error on apply Power Query: Expression in partition n/a in table n/a references an unknown entity

Source = AzureStorage.DataLake("" & DateTime.ToText(Date.AddDays(DateTime.LocalNow(), -1), "yyyy-MM-dd")),


This PowerQuery Source gives a preview without any error, but when "close and apply" this error is shown:

Failed to save modifications to the server. Expression in partition n/a in table n/a references an unknown entity


When I change the source to static string it works fine!?


Source = AzureStorage.DataLake("" & "2020-03-29"),

Status: New
Super User IV

Same here. Tried to copy all queries from one (working!) file to an empty file and got this error. 

When trying to identify the query that caused the trouble I ended up not loading any query at all and the application of that changes (of not any query at all...) triggered the following error-message: 





Frequent Visitor

Hi, @aarongiust and @nicg: you are right!


TURN the "enhanced metatdata format" OFF and restart PowerBI WITH an NEW file (and copyying every formular via windows editor solved this problem!


Thanks Josef

Frequent Visitor

@jofujofu that is definitely a workaround, but not very feasible in most cases, unless you had just started work on your PBIX.


I think the feature should be pulled back out of preview immediately.

Advocate I

I can confirm that this is the reason - without the option "enhanced metatdata format" it works!

But that means that you have to create a completly new PBIX file and rebuild EVRYTHING new, the PowerQuery Sources, all logic, visuals, etc...
Not acceptable.

Super User IV

Hi @Oliverpmone ,

very much agree that this is a pain. Hope Microsoft will fix that soon @v-qiuyu-msft 


I've collected some links that can speed up rebuilding here:



Frequent Visitor

I'm observing the same issue with data from a web source (html content), although it's not mentioned in the documentation. Disabling the 'enhanced metadata format' preview feature, and creating a new file solved this issue, but it will still require a lot work to create a new pbix-file just to implement a minor feature... 

Frequent Visitor

@v-qiuyu-msft , is there an update on whether this will be fixed and when? This will ruin a PBIX file if turned on.

Super User IV

Looks like the April release fixed the bug (Version: 2.80.5803.1061 64-bit (April 2020) ) (.. and even provides some backwards compatibility !!) 

Would love to hear from you guys how this worked out for you.


Frequent Visitor

What makes you say that, are there release notes somewhere? The April release did not resolve the problem for me.

Super User IV

 I tried it on one of my files and they worked fine.

Havent't read anything about that yet.