Showing results for 
Search instead for 
Did you mean: 

Error-Message: Can't display the visual / Couldn't load the data for this visual

Hi Community


We've got many reports based on SSAS multidimensional incl. a huge dimension and this dimension is used within a filter. Now we're getting an error when we want to select all elements (which works fine) and then we deselect one or more elements. This causes the following error:


The query contains a filter with too many values. For queries against this model and server, the maximum number of values allowed in a single filter is 500. Please reduce the number of selected values in the filter.


The problem occures on-prem and online, the issue seems to be new...


Product Version: 2.59.5135.601 (PBIDesktop) (x64)

Release: June 2018


Any ideas / solutions?


Thank you and best regards


Status: Needs Info

Hi @Swiss_BI,


Do you add a dimension column in a slicer visual?

Would you please record to clarify the issue? 


Best Regards,
Qiuyun Yu

Established Member
Status changed to: Needs Info
Frequent Visitor

Hi @v-qiuyu-msft


Actually I'm using the custom visual HierarchySlicer - when I change to the default Slicer, the problem doesn't appear.


1. Adding both visuals - on the left side you see a HierarchySlicer with two dimension levels, on the right side a Clustered column chart:


2. Click "Select All":


3. Click "Apply" - the Clustered column chart shows an error:


4. "See details":screenshot_04.png


Thank you and best regards



Hi @Swiss_BI,


From the error message, the issue is due to the filter values are too many. The Hierarchy Slicer contains two dimensions while we can only put one dimension in a default slicer. Which dimension do you put in the slicer?


As you mentioned the issue doesn't occur with default slicer, please only put the same dimension in Hierarchy slicer visual then test again if the issue occurs. 


By the way, the latest Power BI desktop version is 2.59.5135.781, please update your Power BI desktop if possible. 


Best Regards,
Qiuyun Yu 



New Member


I agree with SwissBI that the issue seems to be new. I have a PowerBI report since quite a while (2016) with a few hierarchy slicers, built on a SSAS 2016 Multidimensional cube. The slicers are holding one dimension each. When I filter on one branch in one specific hierarchy, I get the same error as SwissBI. A subbranch, one level lower, works again. It seems that the number of leave members (lowest level in the branch that I select) exceeds a maximum. But that should not be relevant, should it? The other hierarchy slicers in the report have fewer members and they do not have this issue. When I remove one or two of the lowest levels from the dimension, in the slicer, the problem has gone, but of course this limits the functionality of the report.

I have the latest PowerBI desktop version and it seems I also have the latest version of the custom visual, the Hierarchy Slicer.

Any comments and hints are appreciated.

Frequent Visitor

@Swiss_BI - 


Did you get any solution on the same? As i am also facing the same issue with my Power BI Reports as well.

Frequent Visitor



Unfortunately I didn't get a solution back then. A few days after the issue occured, the problem was solved without any change on our site.


Regarding this issue we decided to replace all custom visuals containing a hierarchy with separate standard slicers (one slicer for each level).