cancel
Showing results for 
Search instead for 
Did you mean: 

Embedded Link Not Updating

Sometimes my embedded link does not update with the dataset. I've noticed that I can open the report in the web browser and click edit then save and it will update immediately.

Status: Investigating
Comments
v-robertq-msft
Community Support
Status changed to: New

Hi,

As far as I’m concerned, the data refresh is different from editing the report in the web browser. The data refresh will not change the report layout, it will only refresh the data it displayed. Therefore, it will not change the embedded link.

https://docs.microsoft.com/en-us/power-bi/collaborate-share/service-embed-secure

 

Best Regards,

Community Support Team _Robert Qin

v-robertq-msft
Community Support
Status changed to: Investigating
 
RodneyB
Regular Visitor

I understand, I'm not making changes to the layout. My issue is that the data refresh either doesn't update the data in the embedded link or it is very delayed. When this happens I can open the report in the web browser, click edit, and click save immediately with no changes, then it will update the data in the report.

v-robertq-msft
Community Support

Hi,

As far as I’m concerned, it’s also mentioned as the technical detail which is explained in the official document:

https://docs.microsoft.com/en-us/power-bi/collaborate-share/service-publish-to-web#how-it-works-tech...

 

Best Regards,

Community Support Team _Robert Qin

RodneyB
Regular Visitor

There is always another disappointment with PowerBI.. I'll find another solution. Thank you