cancel
Showing results for 
Search instead for 
Did you mean: 

Email Subscription Refresh Options for Apps

When scheduling an email subscription, the option to change between daily and weekly notifications is not avaliable in an app when it is avaliable in a workspace for the same report. I have noticed this only occurs when the report contains connections to multiple databases or servers in SQL Server. It does not happen for muliple data sources, or data models with multiple tables from a sinlge database in SQL Server. Since the desired users cannot be in the workspace, the only workaround is to set the report refresh rate to the rate at which you'd like the emails to be sent. If you would like the report to be refreshed daily, but only receive an email once a week, this cannot be done for these particular reports by scheduling the subscription through the app.  

Status: Needs Info
Comments
Moderator

@nox,

I am unable to reproduce this issue on my side. I create a Power BI report which containing databases from different SQL Server instances, and publish an app containing this Power BI report. The end use can see frequency option.

Capture.PNG1.PNG

Do you use import mode to load data from all the tables in Power BI Desktop? Does your app only contain the specific report?

Regards,
Lydia

Moderator
Status changed to: Needs Info
 
nox Frequent Visitor
Frequent Visitor

Hi @v-yuezhe-msft

 

This occurs when using import mode to load the data from all the tables. It was tested with several apps and workspaces, but all contained other reports. The confusion is that all reports show the option from the workspace side, and some do not show it from the app side (where, from a permissions standpoint, the schedule must be applied). I targeted multiple SQL Server instances as a common factor in the reports that had this behavior, but it may not be the specific reason. 

Moderator

@nox,

How about you publish an app which only contains the specific report?

Regards,
Lydia

nox Frequent Visitor
Frequent Visitor
An app that only contains the report does not work. I have tested a report with multiple databases that did not work, then using the same report with just either of those databases worked.
Moderator

@nox,

Do you use any specific features in this report? I am unable to reproduce this issue on my side.


Regards,
Lydia