cancel
Showing results for 
Search instead for 
Did you mean: 

ESRI ArcGIS maps arent saving changes

I am using the free, out-of-the-box ESRI ArcGIS map visual.  I built this visual last year and had no trouble., so this isnt an RTFM situation.

 

I opened the PBIX and the visual looks like it reset to defaults.  Ok, stuff happens so I reconfigured it. 

Well, after saving and going back to the page with the visual, the defaults appear again. 

 

So, now, I have to publish the report (other changes were made) with an ESRI map that looks different because I cant preserve my changes.

 

I'm going to guess I am the only person on the planet seeing this issue, but I'd figure I would reach out take a shot.

 

TIA

Power BI Frustration Level: HIGH

 

 

 

Status: Accepted
Comments
Frequent Visitor

Actually, I am having the same issue. Just noticed it this afternoon. As soon as I navigate away from the page that has my ArcGIS visual, all of the settings revert to default. Otherwise, the functionality does not appear to be impacted. The main concern is that the map's colors no longer match the rest of the report theme.

Regular Visitor

Not sure why but I think I see what is happening.

 

When we click on the "..." then choose "Edit", it puts in edit mode.  We can make all the changes as normal.  To exit edit mode, we need to hit the "Back to Report" option (essentially de-focusing).

 

When I do that, I still see the ESRI edit bar, meaning I havent left edit mode.  So when I navigate to another page, I am essentially quitting the edit mode without saving.  I see NO other way to exit the edit mode.

 

Seems like the visual may have a bug.  I am also seeing other objects appear in my focus mode screen (slicers, other visuals, etc) instead of JUST the visual I want to focus on.  Not sure if others are seeing this or if its related.

 

Regular Visitor

@SQLguy

If I make all my changes to the ESRI Map, then navigate to the first page, then publish the report, I DO see all the changes when I view the report from Power BI Service.

 

Problem is, when I re-open the report later, it will reset to defaults and I will have to re-do all that work again...

Frequent Visitor

Thanks, @ThomVF, but unfortunately that method isn't working for me. Made my changes in Power BI Desktop, switched to the first page of the report, saved the file, and published it to the workspace, but the changes did not appear in the workspace copy. I tried using the "Edit Report" option in the Power BI service, but that also did not work.

Regular Visitor

I tried re-creating my ESRI map on a new page/tab.  The problem with going in and out of edit mode using the "edit" and "return to report" (defocus) options seems to not be present here (but it is not good if I have to rebuild a visual to workaound that issue).

 

However, when I exit and re-enter the page/tab, the visual still goes back to the default settings...

 

I hope someone at PBI-central can take a look at this...

Frequent Visitor

I am having the same problem, I had my BI report published on Friday and today it has all my custom maps set to default. I haven't been able to get my file to save any map changes for publishing.

Moderator

Hi all, 

 

I have reported this issue internally: CRI 116645121. Will update here once I get any information. 

 

Best Regards,
Qiuyun Yu 

Moderator
Status changed to: Accepted
 
Visitor

Thanks, Qiuyun. This is a functionality that is critical for our clients.

Frequent Visitor

Same here, arcgis custom formatting on all reports is gone. Reverts to default on page reload.