cancel
Showing results for 
Search instead for 
Did you mean: 

ESRI ArcGIS maps arent saving changes

I am using the free, out-of-the-box ESRI ArcGIS map visual.  I built this visual last year and had no trouble., so this isnt an RTFM situation.

 

I opened the PBIX and the visual looks like it reset to defaults.  Ok, stuff happens so I reconfigured it. 

Well, after saving and going back to the page with the visual, the defaults appear again. 

 

So, now, I have to publish the report (other changes were made) with an ESRI map that looks different because I cant preserve my changes.

 

I'm going to guess I am the only person on the planet seeing this issue, but I'd figure I would reach out take a shot.

 

TIA

Power BI Frustration Level: HIGH

 

 

 

Status: Accepted
Comments
Regular Visitor

I am facing this problem where the Arc gis maps are not saving changes in Power BI Desktop or on the Power BI server. @v-qiuyu-msft . The basemap color changes and color changes are not being saved.

Regular Visitor

Hi, I am having problems with ArcGIS maps as well. I am using the 1.0.0.104 version. I just change page and come back everything is back to the default color and even the basemap. Is there a solution for this issue? Thank you.

Regular Visitor
 

Having the same issue as many others have reported. I too am using esri version 1.0.0.104 in the Power bi May 2020 64bit version. Using the standard esri function (i.e. no corporate login) I am able to make changes to the base map and change the style to a heatmap. I can exit the edit session and all looks good. However, when i navigate away from the tab and then come back the map reverts to its default settings. Please can a fix be worked on /issued. Many thanks.

Super User IV

Same for me.

If you switch to another page in the .pbix, when you go back to the map page it has dropped the reference layer.
If you save the .pbix with the map page selected, when you reopen the file the map displays correctly.
If you switch to another page then save an close the .pbix, when you reopen it and go back to the map page it drops the refernece layer.
If you publish the file the map page displays correctly even if you switch to a different page on the web then back.

It is the act of re-selecting the map page in the .pbix file that causes the reference layer to drop.

When created the reference layer shows.When created the reference layer shows.Switching to a different page in the .pbix then back the reference layer is dropped.Switching to a different page in the .pbix then back the reference layer is dropped.

I have uploaded my sample file for you to take a look at.

    https://www.dropbox.com/s/ryo0x301d1pngay/ESRI%20map%20sample.pbix?dl=0

Power BI Desktop Version: 2.81.5831.821 64-bit (May 2020)

Super User IV

Update:
I Just installed the June version and that seems to have fixed the problem.

Version: 2.82.5858.641 64-bit (June 2020)

Advocate IV

I can confirm that the June version of Desktop has also fixed this issue for me. Good to see.

New Member

Can also confirm, the June update has fixed the problem for me as well.