cancel
Showing results for 
Search instead for 
Did you mean: 

DirectQuery errors on imported tables. July 2018 Composite Models.

 

direct query errors.png

So, I turned Composite Models preview feature on yesterday to review it. I got the top two errors on my imported tables.

I turned it off and restarted PBID and refreshed all. Then, I got the third error on a different table. I also continue to get the error on the other table.

 

 

 

Status: New
Comments
Regular Visitor

@AlexGorev,

 

I installed the newest version but I'm still not able to refresh my report. I tried with the preview feature 'Composite Models' enabled and disabled. Is there something else I must do? All my sources are import.

 

 error message.png

New Contributor

@VSchepens - did you restore the file before it was corrupted? I am not sure that the new desktop update fixes the issue previously caused. I just know it seems to have prevented it from reoccuring.

Power BI Team

@VSchepens, the new update only prevents this issue from happenning in the future. If you already have a model saved in that state you need to apply the workaround below to fix it:

 

Workaround:

  1. For the broken query, get the query text by right clicking in the query editor and selecting advanced editor.
  2. Create a new query that is explicitly import, such as a CSV file.  Enter any information you want in the get data wizard, so long as it creates a new query.
  3. Right click the new query, select advanced editor, and paste the query text saved in step 1
Regular Visitor

Thank you for fixing this so quickly.Smiley Very Happy

Member

Faster workaround:

Open Query Editor. Click Enter Data. Add a simple table with one column and one row. When you click OK, it will ask you if you want to switch all queries to Import mode. 

 

That did it for me. 

 

BUT, with Composite Models turned ON, it didn't help.

Frequent Visitor

I am not able to upload a direct query from sql server to power bi. It says same error query contains tranformations and can't be used for a live connection.

 

Please help in fixing this issue. 

 

Thanks in advance.