cancel
Showing results for 
Search instead for 
Did you mean: 

Direct Query Issues

I have a couple of reports that are using Direct Query to Azure SQL DB. When i was trying to make a change to the report and trying to publish the file, data didn't load to PowerBI Desktop. 

It kept on giving me the following error image.png

 

 
Status: New
Comments
Visitor

Just FYI, the same query works in Import Mode

Moderator

Hi @mudgilam

 

Which kind of the changes did you made to the report? If you only didn't do any changes in Query Editor, I would suggest you open the report which uses import mode, make the same changes, click on Refresh button to see if there is any issue occurs. 

 

Best Regards,
Qiuyun Yu

Visitor

Hi Qiuyun,

 

The report originally was using Direct Query mode, i just made some changes to the logic of the SQL, basically commented out a where condition. As it turned, all the other reports were also giving the same error.

I just tried using the same SQL in Import to see if it works, turned out it did.

 

So, there's an issue with the Direct Query.